Rhino Stalling when Using Mesh and vertices

I am working on scanned data (mesh) of around 39Mb, Rhino runs nice and smooth for a short period then becomes slow and starts loading for short time and then becomes Okay again.
I have disabled autosave and put mesh settings to fast.

Hi - please post the result of the Rhino SystemInfo command.

What does that mean?

Rhino 6 SR21 2019-12-17 (Rhino 6, 6.21.19351.09141, Git hash:master @ 4d373f64ffb55e3a8d607d9618590728d86fb1e9)
License type: Evaluation, build 2019-12-17
License details: Cloud Zoo. In use by: Nassor Majeed ()
Expires on: 2020-04-05

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: PT-03048

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro K620 (NVidia) Memory: 2GB, Driver date: 12-6-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.66

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-6-2019
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\Flamingo nXt 5.0 (fd53f8c4-546d-47d1-8820-e66c97645a97)\5.5.18100.1000\5.5\Legacy\Flamingo.Legacy.dll "Flamingo nXt Legacy File Reader " 5.5.18100.1000
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\Flamingo nXt 5.0 (fd53f8c4-546d-47d1-8820-e66c97645a97)\5.5.18100.1000\5.5\Flamingo.nXt.rhp “Flamingo nXt 5.5” 5.5.18100.1000

Hi Nassor - Thanks for that.

  • is the 39 MB file a 3dm file or is that the size of the imported file?
  • Can you attach a file?
  • I still don’t know what “[…] and starts loading for short time […]” means

When you only have mesh objects in your scene, changing the mesh settings won’t do anything.

Sorry I cannot attach the file but it is an OBJ file from a 3d scan. What that means is it works fine for a short time then stops working or works really slow. When it stop working the mouse shows the loading(turning) wheel.

I hope that clarifies.

Thank you.

Any Update?


Hi - without a file, it’s hard to try to reproduce things. Is it possible to share it with McNeel? If so, you can upload it on the following page - make sure to add the URL to this discussion in the comments field.

Apart from that, have you tried running Rhino in safe mode to check if the issue persists?

Yes I did try safe mode and there was no difference.
I have uploaded the file to the page you gave me. It is a much bigger file than the one before but I am also using another System that I believe is able to handle such a file. Here are the system specspc spec .txt (1.7 KB)

Thank you.

Hello - I see some problems opening your file as well - I don’t yet have a good idea what but Check does not like it at all so far.
Hm - well, it is 10 million vertices…

@nassor1738 - one thing to try is to SplitDisjointMesh - wait for that to happen (go get a coffee) and then go around and selectively rejoin parts or delete them, move to different layers, etc so that you can deal with a subset of the mesh at a time rather than all 10 million vertices.