Rhino slow saving

Hey guys having same issue. please help me.

system info:
Rhino 7 SR33 2023-9-5 (Rhino 7, 7.33.23248.13001, Git hash:master @ 332dda7497b18e9e6f82f118da5cba0c448151a9)
License type: Evaluation, build 2023-09-05
License details: Cloud Zoo
Expires on: 2023-11-01

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 7.8Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1650 (NVidia) Memory: 4GB, Driver date: 6-2-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 532.09
> Integrated accelerated graphics device with 1 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 6-1-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-2-2023
Driver Version: 31.0.15.3209
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp “Datasmith Exporter” 5.2.1.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.33.23248.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.33.23248.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.33.23248.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.33.23248.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.33.23248.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”

Hi Nick -

We’ll need more information. Can you describe the issue?
Is this file-specific or does “it” happen in a new file with only a simple box?
Are you saving to a local disk or to some network location?
Have you tried disabling the Datasmith plug-in?
-wim

Hi Pascal This file is 650mb and It takes too long to save the file
Shoul I try it ? (For Rhino7)

woww I do it and That’s it greatt what is problem ?

Is there a solution for boolean commands Please

Put your question in the original thread. The Boolean command question has nothing to do with saving a file.

2 Likes

Thank you David

Just reporting:

Rhino 7, a file of 618MB was taking 3 minutes to save on desktop (NVMe SSD, 5800X cpu , etc…)
Turned off UseCompressionWhenSaving and now it takes 10 seconds… 704MB … I can live without compression.
(WriteLocalTempFileWhenSaving was already on…)

3 Likes

Ikr! :sweat_smile: :beers: This used to be such a mystery to me for yrs n’ yrs. Now when I see this topic I’m like yep turn that off :grin:

But then I go to upload something here n’ it’s more than 20MB :rofl::sob:

1 Like

Saving finished too soon with Mcneel Rhino 8 , Rhino 7 is very late , so I have to buy rhino 8
But for mcneel a question: aren’t Rhino 8 and 7 same platform :confused:

check ‘compression’ in each.

1 Like

actually I’m having big trouble with the boolean command , boolean command finished too soon my object has many faces, vertices edges

This is a different problem, please start a separate topic and include a better description and a sample file to test.

1 Like

I am also experiencing a similar issue in both v7 and v8. Regardless of file size (the latest i’m working on is about 9MB) rhino will sometimes save at regular speeds (a few seconds) but most times it takes what feels like a minute plus. This only worsens the larger the file size gets.

Rhino 8 SR8 2024-6-18 (Rhino 8, 8.8.24170.13001, Git hash:master @ c3cc7c123163b65d85b517aff795627d5b12166b)
License type: Educational, build 2024-06-18
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 40GB)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) Iris(R) Xe Graphics (Intel) Memory: 1GB, Driver date: 12-12-2022 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3070 Ti Laptop GPU (NVidia) Memory: 8GB, Driver date: 6-1-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 555.99
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

Secondary graphics devices.
Trigger 6 External Graphics (Magic Control Technology Corp.) Memory: 0MB, Driver date: 4-24-2024 (M-D-Y).
> External USB display device with 2 adapter port(s)
- Secondary monitor attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-1-2024
Driver Version: 32.0.15.5599
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Users\Xavier Raymore\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\Lumion LiveSync for Rhino (839d6175-32d1-4ffe-a0a4-b7fb43cf0ff5)\2021.3.25.899\Lumion\Rhino 7.0\LumionPlugin.rhp “Lumion LiveSync for Rhino”
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp “Datasmith Exporter” 5.0.3.0
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.8.24170.13001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.8.24170.13001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.8.24170.13001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.8.24170.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.8.24170.13001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.8.24170.13001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

@Xavier_Raymore Are you saving to a local disk in or directly attached to your computer, or to network or cloud storage?

Try disabling the “Lumion LiveSync for Rhino, Datasmith Rhino Exporter and V-Ray for Rhino plugins, restart Rhino and see if the problem continues.

Does you file have many groups or textures?

Appreciate the quick response David. I have noticed this same slow save time when saving straight to my harddrive as well as dropbox. I disabled the plugins like you suggested, no change.

hi @Xavier_Raymore saving takes time due to file compression, but this can be turned off
In advanced settings look for
Rhino.Options.Advanced.UseCompressionWhenSaving

Let me know if that makes a difference for you.

1 Like

I see you use V-Ray. In my case I have noticed that it’s the source of the “slow save”. Like you I experience it for most of the saves, but not all of them.

To try it out you have to completely disable the V-Ray plug-in, not just change the current renderer. You have to go to Options > Plugins and untick V-Ray. And then restart Rhino.