Rhino server error

Ive just tried installing different versions of rhino but the only link that fails is when you specifically click on the evaluation version for 90 free day trial

1 Like

Hi -
We are aware of this issue.
It looks like this is something that needs to be fixed by our people in the Seattle office.
This thread will be notified when the server is back to functioning as it should.


Same problem in Portugal to…

1 Like

Same problem in finland

Same problem in Brazil

Same issue in the UAE

Same problem in Croatia

Same problem in UK

Same problem in France

Same problem in Austria

Same in italy

same in Poland

Same in Denmark

le serveur ne fonctionne pas depuis hier

Hello, I got the same error page in New York

1 Like

same error page in Taiwan too

Thanks for all the reports. The issue does not appear to be specific to any particular location/language. We should have it fixed shortly.

The error has been fixed. Thanks for your patience!



I’m experiencing this issue with the Rhino 7 Evaluation edition. I can download the regular Rhino 7, but when I try to reach the Evaluation edition, I get the 503 Server Error.

Thanks for reporting. We are looking into it.

Edit: Its up, there was about a 30 min infrastructure disruption.