Rhino "self isolation" issue w/ textures

Hello everyone,
I am writing to report an issue that might plague a lot of us now that the whole world is working from home, it seems.

We’re observing huge lag when working on models that were previously worked at the office. I’ve narrowed it down to this:

Rhino is trying to find textures that were saved on our local server. It fails and eventually shows the “missing textures” panel. That’s 100% understandable.
Unfortunately that takes a lot of time, and any subsequent action involving said missing textures (for example selecting the material, or the object to change it) also leads to a long freeze.
The file doesn’t fail, so what I think is happening is that Rhino is looking for the server until whatever it’s doing times out, and then unfreezes.

Given that the issue is extremely widespread and that every action freezes Rhino, it’s almost impossible to do what I know would fix this, which is manually relink any missing texture to something else.

Can anyone think of something that might help?
Thank you all in advance!

Hello - were these files saved without the textures, do you know?


Hi Pascal,
I’ve tried both. The problem persists regardless. Rhino doesn’t “pull” all the textures when saved from the server with “Save Textures” selected (which is a whole different issue).
After the fact and working remotely, any broken link that points to the server just freezes everything.