Rhino running so slow on brand new iMac


#1

OS X EL CAPITAN version 10.11.4 and oh my gosh it is painfully slow. I’ve looked at some other similar questions and haven’t found a relevant fix. Any help would be greatly appreciated. I don’t know if it is the size of the file or something with the settings and am actually not sure how to determine the file size.


#2

Give us some info on this imac components like what cpu it has or gpu etc. And how big is your scene using polygoncount command


#3

Hi @Petra_Winnwalker send your specs, you can get this from Rhino. Go to Rhino in the menubar and select About Rhino …

Then in the next Window select More Info …

Then in the next window select copy to clipboard and then past into your reply here.

Select you file in Finder and look at the preview


#4

So when I export the selected parts of the file it says it is 1543Mb.

Under CPU, it looks like 95.92% is idle.

And attached is the Rhino specs

Let me know what you think. This is all quite new to me but I haven’t had this much trouble with any of the other files.
Thanks!


#5

For what is my daily experience with large files (using El Capitan), the only way to work in an efficient way is to open the file, cmd + c of the part that we have to work, open a new file empty, cmd + v to work on it.
8 gb of ram are very few to work with Rhino Mac (keeping other open App). If you decide to increase the RAM, better to close all apps that consume so much RAM when modeling with Rhino. We recommend opening monitoring and test the behavior of the Mac when modeling. I get significant slowdowns with the 400mb file up …
Only for the sake, working with standard settings?
Simon


(Dan Belcher) #6

Hi @Petra_Winnwalker-

Thanks for this report. Can you please do me another favor, can you include the more complete system report that gets copied to your clipboard when you click the Copy to clipboard button (Rhinoceros > About Rhinceros > More Info… > Copy to clipboard)?

-Dan


#7

Hi there, here it is. The file size issue was mostly resolved by converting
to meshes and then reducing them. There do seem to be some glitches that
potentially aren’t operator error.tx.


#8

Hello @Petra_Winnwalker click the “Copy to Clipboard” button and “Paste” into your reply.

Does that make sense?

Tou will get something like this …

Software information

Software versions
Rhinoceros version: 5.3 WIP (5D132w)
IronPython version: not installed
Language: en (MacOS default)
OS X version: Version 10.11.6 (Build 15G31)

Plug-ins
/Users/randygregory/Library/ColorPickers/SkalaColor.colorPicker/Contents/MacOS/SkalaColor

Third party kernel extensions
at.obdev.nke.LittleSnitch (4718) 715E9654-C3FB-39A4-9514-C770F749EE8E
com.intel.kext.intelhaxm (6.0.1) 8FF2C637-0A5E-367E-B007-5B08655B1E8A

Hardware information

Computer hardware
Hardware model: MacPro2,1
Processor: Intel Xeon CPU 5150 @ 2.66GHz
Memory: 22 GB
Architecture: Intel 64 bit

Video hardware
Graphics: ATI Radeon HD 5770 1024 MB
Memory: 1024 MB
Screen size: 1680 x 1050, 1920 x 1200
Displays: Cinema (99dpi 1x), BenQ FP231W (98dpi 1x)

USB devices
Digidesign: Mbox 2
Hewlett-Packard: hp LaserJet 1000
PixArt: DynexWired USB Optical Mouse
Apple Inc.: Apple Keyboard
Apple Computer, Inc.: Apple Cinema Display

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-1.42.15
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


#9

Yes, that does. Thanks.

Software information

Software versions
Rhinoceros version: 5.2.4 (5C262)
IronPython version: not installed
Language: en (MacOS default)
OS X version: Version 10.11.4 (Build 15E65)

Plug-ins
None

Third party kernel extensions
None

Hardware information

Computer hardware
Hardware model: iMac17,1
Processor: Intel Core i5-6500 CPU @ 3.20GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: AMD Radeon R9 M380 2048 MB
Memory: 2048 MB
Screen size: 2560 x 1440
Displays: iMac (217dpi 2x)

USB devices
Broadcom Corp.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)

Bluetooth devices
Broadcom: Magic Keyboard
Broadcom: Magic Mouse 2

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-1.42.6
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


#10

Ciao
I understand that the file was in mesh (or was exported in .stl mesh). Am I wrong? If so, it is normal that the system slow down with that size. It would need a much more powerful machine for working with very large mesh files.

Buona modellazione

Simon


(Dan Belcher) #11

Thank you @Petra_Winnwalker. I do not see any red-flags that would explain why this might be running slow. As some alluded to above, if this persists, we may need to take a look at your preferences file as well. Reproducing these sorts of issues is generally quite difficult.


(Marlin Prowell) #12

I think the issue is what is in your 3DM file, and not with your Mac itself. Perhaps there are large dense mesh objects in your model and they will slow down drawing. We’d like to see a copy of your model so we can duplicate what you are seeing.

Upload a copy of your model to http://www.rhino3d.com/upload. In the comments section, add Attention: Marlin and also mention this Discourse thread.

How did you create this model? Did you import a file? If so, please also upload the original file.

Thanks.


#13

I’m confused. It shows iMac17,1 which is the current model, but the current model is Retina display only, but your screen size indicates it’s not retina?

That said - while you got the latest iMac, it appears that you got it with the lowest available specs in terms of RAM, Processor and graphics processor, and the reality is that is going to make life difficult with something as intensive as 3d design… especially the 8GB ram. I run an i7 iMac with 32GB and I sometimes have memory issues when running Rhino (Granted I also have Safari, Photoshop, Quickbooks, Mail and usually a few other apps open at the same time). I suspect if you max out the RAM you’ll see a big improvement. Also not addressed in your specs is your hard drive. In theory solid state or Fusion drive should give better performance.


#14

Thank you, I will look into increasing RAM.