Rhino render color picker causing rhino to crash

It looks like that makes 3 people in a row reporting the same crash bug - all using Vray. Can you reproduce the crash when you start Rhino in safe mode - simply switching to an other renderer isn’t enough.

Strange. I tried it in Safe mode, it worked and now it works in normal mode also. Before that, I tried with the renderer selecter to rhino and vray without any difference, it was always crashing.

I am having crashes with color picker. I do not have Vray, but I have Maxwell. Running in safe mode seems to load a different looking Material editor than the one loading from normal version. No crashes in safe mode. I tried un-installing Maxwell to see if it is the culprit, but I still get crashes. It is repeatable.

Actually just clicking on certain parts of material editor window crashes rhino for me.

Running R10 on Windows 7 64bit

I noticed this happening too recently. Rhino has been fine right up until about a week ago and then suddenly crashed every time tried to pick a material. It seemed to coincide with a windows update. I was going to try a uninstall/reinstall but did the repair option instead in Programs and Features and now it works fine.

Hope this works for others.

FreekeeDeekee, I tried the repair option. Unfortunately it didn’t work for me. I am not sure a full re-install will make a difference. It seems to be a bug of sorts. I guess if need be I can just go through the render area and assign colors and materials rather than using the layer material editor.

Hi Talos - so, with Maxwell currently not installed, and having done a ‘Repair’ on Rhino, (Correct?), what steps, exactly, causes the crash?

thanks,

-Pascal

Hi Pascal

I click on the circle to the right side under Material column of the layers. The editor opens up with a spherical icon indicating current material. Under the color option, when I pick color picker from drop down menu, then I get the blue ring of death and Rhino basically crashes. As mentioned I ran Rhino in safe mode, and the material editor seems different (I am not sure if it’s just a simpler version of the editor running in safe mode). Anyways, color picker works fine in safe mode. I am trying to re-install Rhino and plugins to see if it helps.

UPDATE: re-install did not solve the issue. I still get the blue ring of death and Rhino crashing. This time I ran Rhino before installing Maxwell again.

Ok. I did a second re-install and now it seems the color picker for layer material editor is working without a crash (fingers crossed). So a re-instal may fix things for some people. I am not sure what caused the problem, but it may have been a windows update that broke something.

So. I am noticing Rhino crashing again when I click on the color picker or even color option of the layer material editor window. It was working fine, but something is broken. I am at a loss at what it can be.

Hi Talos -Does the McNeel crash report interface show up on these crashes? If so, are you sending the reports?

@jdhill, do you have an idea? It seems at least in some cases Maxwell might be in the picture.

thanks,

-Pascal

Pascal, I am not sure. I don’t see a report window. The app just dies. If I try clicking on the app window, I receive the typical Windows message asking if I want to kill the app.

Screen grab of what I see as far as the editor goes. Is this Rhino’s or Maxwell’s editor? Notice the “Not Responding” notice on upper left…middle of a crash.

The crash seems to be somewhat random. Picker works ok for now. But I had to restart my computer.

Hi Talos- thanks - yep, that is Rhino’s control - so, am I correct that you never see the color picker at all after the click, or does it turn up and crash or? I think we tried this with Maxwell and/or Vray blocked, in Options > Plug-ins (restart Rhino), is that correct? Can you verify that this still happens without one of these rendering plug-ins loading at all?

thanks,

-Pascal

Today, instead of killing the app after clicking on the color option and having Rhino break, I just let it be for a few minutes. Then I see the color picker showing up after a long delay (kind of strange). Now, yesterday I un-installed Maxwell and was still getting the crashes. As of now, it seems to be working ok.

@johnc, do you have an idea about this? thanks,

-Pascal

Hi Pascal, I’m not yet able to observe anything like this here. My first question when dealing with weird behaviors like this is usually, what are the chances we’re running in a virtual machine. Secondly, I notice that in the screenshot, it looks like KeyShot and T-Splines are also loaded, so I’d ask about checking with those disabled/uninstalled, too, just to be sure.

This looks like a duplicate of TangentLaser’s 2nd problem in this thread:

This annoying problem is rare and difficult to reproduce. It is not related to V-Ray or Maxwell, although the presence or absence of any plug-in, or a reinstall might influence whether or not the bug shows up. It is actually caused by a bug in very old core Windows code which we have to carefully work around. I believe I have fixed this in SR11; at least I can no longer reproduce it. Please let me know if you are still seeing the bug in SR11.

Thanks,

John

Thanks Jeremy - I guess JohnC has a handle on this in the meantime.

@talos72, can you please install the SR 11 release candidate and see if that does anything good? To get SR 11, go to Options > Updates and Statistics and enable “Service release candidate” in the “Update frequency” field.

thanks,

-Pascal

ok. NP

Nevermind, it was good for a while but it’s doing it again :pensive:

4 posts were split to a new topic: Crash on material assignment