Rhino Raytraced View Mode Not Recognizing WIndow Glass as Separate material from other window elements

Any update on this @fsalla?

We’re seeing some weirdness in Enscape as well with issues related to mapping? Do you have an explanation, if this is related to Enscape or VisualARQ?

1 Like

Hi Roi,
Unfortunately there are no news of improvement of VisualARQ objects with Rhino 6 raytraced display mode.
Regarding the issue with Enscape, the texture mapping visibility should be the same as if that wall was a Rhino block. Please let me know if blocks with textures have also mapping issues in Enscape. If they don’t, then it might be an issue with VisualARQ objects that we will take care to fix.

Here’s an extrusion that’s been texture mapped and then blocked:

Is that what you were thinking about? Entering that block and changing the Texture Mapping also works

All right, we will revise how VisualARQ objects with textures are exported to Enscape and get back to you when we know more.

1 Like

Hi Roi,
It looks like this is on Enscape side.
Perhaps you can reach Enscape developers for more information: support@enscape3d.com

Hello Francesc!
Like Rheinason, I run into this UV bug. Please be so kind and look into the thread in the Enscape forum:


Hi Eugen, my colleague Enric Marques has contributed in that Forum.

Read it, thanks a lot!
Too bad if there’s a Rhino bug involved that only get fixed in R7… my hope was to render my diploma project as hassle-free as possible… =[
Anyway, workarounds will have to do. Looking forward to the fix!

How about with (the pending) Rhino 7?

I’ve had problems in Rhino3D, with Rendered mode, assuming that objects behind glass do not need to be draw and/or correctly. It’s was like it applied the materials with no mapping, kind of the old hall-of-mirrors thing.

Hi @djhg, @Eugen, @rheinason, we have recently released VisualARQ 2.13 which fixes some issues of displaying VisualARQ objects and materials with the Rhino Raytraced mode.

We have also added a change to make textures on VisualARQ objects display properly in Enscape.
(VisualARQ objects do no longer share geometry between identical objects if they have a custom mapping applied). Running vaUpdate on existing objects may be necessary.

More details: VisualARQ 2 - Version 2.13 released

1 Like

Hello Francesc,
With VA updated the raytraced view doesn’t recognize any VA objects…
Cheers, Jaro

Hi Jaro, what Rhino version do you have? Can you share a sample model to test?

Hello Francesc,
It’s the latest Rhino 6 and Visual 2.13. With the previous Visual everything was OK.
The problem is even with a plain model, just a new file with a single wall, a shaded view:

A realistic view:

And finally a raytraced view:

The same camera settings, display views set to defaults.

Cheers, Jaro

Hi Jaro, that’s weird! I’m testing this with VA 2.13 and Rhino 6 SR35 and it works well.
Are you using the SR35?
In your Raytraced mode screenshot, I don’t see any “rendering” information at the bottom of the viewport.

Is your last screenshot done with the Raytraced mode?

Do you see Rhino geometry in Raytraced mode?

Do you have the RhinoCycles plug-in enabled?


Well, it is strange… All plug-ins are enabled, except Rhino Cycles… Enabling it gives such an info at the Rhino start up:

I think it could have something in common with Windows 10 update, and I cannot get through it. Its error code is 0x800f0922 and, as almighty internet says, it’s almost unpassable now.

Frankly, I don’t use raytracing almost at all, I was just curious if you know anything about the problem.

Cheers, Jaro

That’s great news, but it’s still not working for me. Maybe you can recommend something.

It’s not working for me either. This test was from a new visualarq template.

@djhg @arcus are you using WCS materials? Unfortunately, Enscape doesn’t work well with WCS materials from Rhino. This is something that happens with Rhino geometry and also affects VisualARQ objects. Unfortunately, we can’t help it.

This has been reported on the Enscape Forum: no wcs mapping in enscape? - Rhino - Enscape Community Forum
If you are not using WCS materials but just textures with a texture mapping applied, then please share the files so we will take a look, because this should work properly.

I see. I was under the impression the update applied to WCS materials. I generally try to avoid using mapped materials scales since it becomes tedious to keep them all updated. I’ll give it a try to the mapped materials.

I’ve noticed the WCS mapping appears to work well with D5 realtime renderer.