Rhino only detects 64mb video ram


#4

Thanks for the reply. Yes Ive restarted many times. Pulling my hair out now trying to get this to work. Ive uninstalled and tried many different drivers for the card as well, still always displays the same result.

  • Sam

(Mary Ann Fugier) #5

Hi Sam.
Thanks for contacting us at tech@mcneel.com.

As we discussed, this is not a Rhino problem, this is an Nvidia issue.
Currently there currently no good drivers for Quadro Nvidia K1100M and others, running under Win 8/8.1. Here’s what we know currently about the nvidia cards:

We do not know when Nvidia will update their Windows 8/8.1 drivers, but Nvidia support is aware of the problems. Going back to Windows 7 means that you have better drivers and better performance from your Nvidia card today. Nvidia makes a good card, but their drivers have been up and down this past year.

Sorry about the problems.
Sincerely,
Mary Fugier


#6

Hmm, I have the Quadro k1000m (2048MB) and I am seeing the same thing. From what I can tell my drivers are all updated to the most recent versions.

I am running Windows 7 pro sp1

It doesnt seem to affect the performance though. My computer did reasonably well in the holomark2 benchmark.


(Mary Ann Fugier) #7

Hi Wattzie,
Thanks for sending the screen captures and the details about your system.
So odd, I have never seen a NA for driver information on the OpenGL panel.

Let me copy this to developer Jeff Lasor @jeff and see if he can give us some insight.
Sincerely,
Mary Fugier


#8

I’ve solved the problem by switching back to Windows 7… works perfect now (: I guess Windows 8 + Quadro + Rhino is just a bad bad combination for now. Thanks Mary for the assistance.

I dont know what the issue with yours is though Wattzie. My card is the K1100m though not the K1000m. That screen was pretty much what I saw when I was on Windows 8. Kept telling me the driver was N.A. Hope you get this sorted out soon.

Cheers
Sam


(Jeff Lasor) #9

The way Rhino “detects” any of this stuff is through the use of the MMC and Registry keys. In some instances that information can get messed up or even exist in completely different areas or even exist in slightly different formats. Unfortunately there are no well defined function calls that can be made to get this information, it’s more of a hunt-and-peck approach. Obviously there’s a way to get the information correctly and consistently since the OS seems to be able to do it, but so far I have found no single method that works on ALL OS’ and SPs. XP was/is the worse.

That being said, it really isn’t anything to worry about. This is just text information being filled in, coming from other text information within the Registry. Most of the time it works and is consistent with what the OS says, but if/when things don’t match with the OS, it doesn’t mean that Rhino won’t use all available memory…it just means Rhino’s dialog is getting the information wrong. I realize it can be confusing, but the OpenGL settings page is primarily supposed to be used for diagnostic purposes and not for system info or validation.

I will look into why things seem to be wrong more often than not on Window 8…but for now, please don’t hang any weight or importance on the information you see in Rhino’s OpenGL settings page (other than the configurable options).

-Jeff


Why Rhino only detects 64MB of my GTX860m
#10

Not all Quadros - I am running Windows 8.0 on one workstation with a Quadro 4000 and 8.1 on another with a Quadro 2000 and don’t have any problems with either. I am using somewhat older drivers though.

–Mitch


(John Brock) #11

You’ve always been special Mitch…


#12

Interesting. Maybe its just the K1xxx series then.

Thanks for the clarification Jeff. I dont know if its just a placebo effect, but I did notice Rhino ran smoother after I switched to Windows 7 and it detected the card properly. Dont take my word for it I guess. Rhino is one of the more important programs right now for me so when the whole Windows 8 thing gets fixed maybe Ill give it another shot. However I’m more than happy to stick with Windows 7 so I’m not complaining!

Cheers
Sam


#13

Sam, did you happen to run the holomark2 benchmark on both setups? It would be interesting to see the difference between the two.


#14

Atlas no. I didnt think about it. I can try testing it now on this setup for you though! Then you can compare the two to see if you are losing a lot of performance.

-Sam


#15

Where did you download it from? Says its in beta and I cant download it anywhere.


#16

Hmm, Maybe it has expired by now. Perhaps @Holo could extend the trial for you?


#17

I am running a Dell M3800 with the K1100M on Windows 8.1 and I have the same problem. I haven’t actually noticed anything wrong until I read this thread. When Holomark2 comes available I will post the results to compare the WIN7 ones against.


#18

Same issue other system.
I am using windows 10 on my new workstation and have issues with my quadro m4000.
rhino and holomark 2 are only detecting 4gb of ram but there should be 8gb :confused: are there still the same issues with that? Or is the card new to rhino?


#19

Mitch,

do you actively not update drivers? I am an update obsessive but honestly I sometimes wonder if I am shooting myself in the foot.


#20

he he :slight_smile: , actually i deal the same way with updates as you are doing, i always go for the latest updates. Got the workstation and card on friday, first i tried the delivered drivers but it was the same like the latest drivers which i updated today. My hope, this issue will disappear since nvidia set the date for launching the card officially to october. maybe it’s still to early


#21

Hi,

Same here.
Bought a new Dell Precision M3800.

  • Installed windows 8.1

  • Installed newest nvidia driver

  • Rhino options:
    -Total Video Memory 64mb
    -Driver Date NA
    -Driver Version NA
    -64mb (newest video driver)

  • Ran Holomark2 (forgot to save the screenshot) with a Total Score:
    22238

  • Installed windows 7 again:


#22

Upgrade to windows 10 incl. nvidia drivers for win10:

anyone experiancing the same issues?

Win7 seams to be the best option for now…


#23

Hi @jeff , I contacted NVIDIA support and this is the copy of the chat (sorry for the long post):

Zia: Hi, my name is Zia. How may I help you?
Thomas Brandwijk: Hi, I have a Quadro K1100 (notebook) and windows 10. I just installed the latest drivers, but I measure a significant difference between win7 and win 10.
In Rhinoceros 3d, win10, it looks like the card is not reconised.
Zia: I apologize for the inconvenience caused and I’ll do my best to assist with the issue
Zia: Do you have NVIDIA control panel installed?
Thomas Brandwijk: yes
Thomas Brandwijk: I will send you the screenshots:
Zia: NOTE: Please select Custom (Advanced) while installing the graphics drivers and on the next screen please place a check mark on perform a clean install
File attachment upload has started.
The file win7.png (164.26KB) was received.
File attachment upload has started.
The file win10.png (159.8KB) was received.
Thomas Brandwijk: Yes, I did that
Zia: Please go to NVIDIA control panel->system information->display->save the file and send it to me.
Thomas Brandwijk: in the attached files the system info is also visible
Thomas Brandwijk: I will send it
File attachment upload has started.
The file win7b.png (302.8KB) was received.
File attachment upload has started.
The file win10b.png (225.37KB) was received.
Zia: I need the system information file from NVIDIA control panel
File attachment upload has started.
The file NVIDIA System Information 10-13-2015 16-04-49.txt (3.86KB) was received.
Zia: Thank you for the attachment
Zia: Please open settings->updates and security->check for window updates send me the screen shot
File attachment upload has started.
The file unnamed.png (1014.91KB) was received.
Zia: Thank you for the screen shot
Zia: I see that some updates are pending to install so install all the updates then restart the computer then follow the below steps
Zia: a) Open NVIDIA Control Panel --> Manage 3D settings.
b) Go to Program Settings tab.
c) Add the file you launch the program from by clicking on Add button.
d) In the setting window, change the ‘Power Management Mode’ to ‘Prefer Maximum Performance’.
e) Run the program and check.

NOTE: If you are unable to locate the .exe file, you can right click on shortcut and go to properties. Select Open File location.
Imgur

Also below settings as well:
. Vertical sync- Off
. Threaded optimization - off
. Triple buffering – off

Please set to these settings and click on apply.
Zia: Did you check?
Thomas Brandwijk: almost
Zia: OK
Thomas Brandwijk: yes
Thomas Brandwijk: I already did change the settings for all programs to: Workstation App - Dynamic streaming
Zia: Did you install the window updates as well?
Thomas Brandwijk: and maximum performance
Thomas Brandwijk: yep
Thomas Brandwijk: other users experience the same problem (rhinoceros forum)
Zia: Is the application is optimized for window 10?
Thomas Brandwijk: jep
Thomas Brandwijk: in the two screenshots I send, you see the difference of the video and driver information
Zia: Yes
Thomas Brandwijk: win7- 2gb total video memory
Thomas Brandwijk: win10- 64mb
Thomas Brandwijk: also Driver Date: NA
Thomas Brandwijk: en version
Zia: Please try with the below driver : http://www.nvidia.com/download/driverResults.aspx/92522/en-us

NOTE: Please select Custom (Advanced) while installing the graphics drivers and on the next screen please place a check mark on perform a clean install
Thomas Brandwijk: I will try, downloading: 6min remaining
Zia: Ok
Thomas Brandwijk: installing
Zia: ok
Thomas Brandwijk: shall I reboot? (this chat is on another pc)
Zia: yes please
File attachment upload has started.
The file NVIDIA System Information 10-13-2015 16-37-36.txt (3.86KB) was received.
File attachment upload has started.
The file unnamed (1).png (452.82KB) was received.
File attachment upload has started.
The file unnamed (2).png (352.43KB) was received.
Zia: Did you add the app in program settings?
Thomas Brandwijk: yes
Thomas Brandwijk: I also tried the setting: OpenGL rendering GPU to Quadro K1100
Zia: You will have to contact application developer to check with them as the application is made for window 10 or not
Thomas Brandwijk: I allready did and it does support windows 10
Zia: But its not working with window 10 as the same card was working in window 7, you will have to check for patches or pluggin for the application
Thomas Brandwijk: Ok

NVIDIA System Information 10-13-2015 16-37-36.txt (3.9 KB)