Rhino on Linux?

I’ll wait for your script then. It’ll be interesting to see what you did to get it working and whether this works on other machines then as well :slight_smile:

3 Likes

So I’m not finished with the installation-script yet, but I’ve already created the instruction! :grinning:

Link to my instruction: GitHub - cryinkfly/Rhino-3D---Linux-Wine-Version-: This is a project, where I give you a way to use Rhino 3D on Linux!

2 Likes

I’ll try Lutris then, although I was hoping for just simplest Wine (: I’ll report back when I’ve managed to try it.

edit:

@cryinkfly looks like Rhino 7.9 is now installed successfully, but running it I guess is still a bit problematic. I see in my process list:

nathan@blender ~/.rhino7 $ ps aux | grep hino
nathan 120037 10.4 0.9 1986600 158176 pts/1 Sl+ 16:58 0:20 c:\Program Files\Rhino 7\System\RmaErrorReporting.exe ud=C:\users\nathan\Desktop\RhinoCrashDump.dmp u=C:\users\nathan\Desktop\RhinoCrashDump.3dm u=C:\users\nathan\Desktop\RhinoCrashDump.gh rhinover=7.9.21201.13001 build=20210720 pid=0336

This means Rhino crashed and now the reporter exe is trying to send the crash info to our crash processing.

Not sure yet why it would crash, but I’ll check later on what I can find.

At least Rhino installed, so one step closer. Thanks for the instructions.

edit2: I realized just now I can just move the .dmp file to my windows box to investigate what it says. I’ll do that when I have some time (still trying to have some vacation :wink: )

3 Likes

Hey Nathan, can a regular user try installing on Linux without worry for license issues or something? Since the license is sold as Rhino for Windows

1 Like

I have to say I don’t know what the legalities are here, but I think no-one at McNeel would object running Rhino like this, as long as you are using a valid license.

2 Likes

Rhino isn’t written for or supported on Linux. If you purchase a license and can get it to work, we won’t complain or try to intentionally take it away - but we also don’t expect it to work well. If we accidentally break your ability to run Rhino on your favorite Linux platform, we won’t put effort into restoring its function. You are welcome to return your license at that point for a full refund.

3 Likes

I can understand it, but for myself it’s unacceptable and that’s why I started to make Rhino 3D run on Linux with the help of Wine. So that you no longer have to access Windows or macOS as the operating system just to be able to use one or more programs for your tasks. :gear:

In any case, I’m happy to be able to help other people to use this wonderful program also on Linux, even if everything doesn’t work 100% properly at the moment. :warning:

But I think, with the support of the community, we can also be solving this problem in the future! :blush:

5 Likes

I looked at the crashdump that was generated on my system. In it the Windows version is set to be 6.2.9200, and that is obviously incorrect. Especially since I set Wine to Win 10. The crashdump further gives no useable information other than that only a few of the DLLs were loaded before the crash happened. No good callstack. The wrong Windows version is currently the only clue.

@cryinkfly let me know if I can help you with more info to get this solved.

1 Like

I was already familiar with the Windows 10 configuration in Wine. This is already done with the help of winetricks (see my instruction on my GitHub-Channel). :sweat_smile:

Then it’s so that the Installation of Rhino3D check which version of Windows is in use on your system and if you have for example Win7 then you get a error. :warning:

@cryinkfly let me know if I can help you with more info to get this solved.

Any help I can get is very good to make the program work on Linux. :+1:

Thank you for your help! :clap:

But if it’s possible, to publish the bug reports, etc. in the future on my GitHub-Project, then this makes it easier for me to coordinate the whole thing. :blush:

1 Like

I have published a new video where I rendering a spare part for a hook rail. :grinning:

Here is the link: Mithilfe von Rhino 3D unter Linux ein Bauteil rendern lassen - [DE] - YouTube

2 Likes

Hi Steve, gratuliere und Hut ab für deine Bemühungen.

3 Likes

So here you can see that the thickness analysis works. :blush:

Link: Rhino-3D---Linux-Wine-Version-/thickness _analysis.png at main · cryinkfly/Rhino-3D---Linux-Wine-Version- · GitHub

4 Likes

Okay, you are now my favourite Rhino dev. I’ve been dreaming of the day somebody at McNeel said they’d like to see Rhino work on Linux.

4 Likes

Thank you for your great feedback! :slightly_smiling_face:

1 Like

@cryinkfly Did you ever manage to release the installation script ?
I am following your instructions but I don’t manage to make it work.

I have tried hard, the closest i got, I managed to add my activation key but then but my environment is not able to handle the response from the servers when trying to validate the key.
I tried 2 different accounts:

*** 1: with an expired evaluation key: On that case the environment could process the response from the servers and showed a message telling the license was expired.
*** 2: with a valid evaluation key: On that case the response from the servers could not be handled, and therefore the license was not validated.


Thanks for your work. It is of great value I believe.

When the installation works without any errors then YES. :slightly_smiling_face: