Rhino on Linux?

So as I commented yesterday, I tried to install Rhino 6 using Evaluation license through wine and surprisingly I succeeded. I installed it using standard, not staging version of wine 5.1 (that is the one that is currently in my repositories). At first I created fresh wineprefix, installed dotnet462 through winetricks and started the Rhino 6 installer and it did exactly what you mention, it crashed during VC redistributable 2005 installation, but surprisingly it seems that only GUI of the installer crashed at that point. As I did run this installation from a terminal window, I left this terminal open after the GUI crashed and it seems like the installer did finish installation of Rhino, I am not sure what actually happend there :). I deleted this wineprefix and started a new one where I installed vcrun2005 and dotnet462 through winetricks before trying to install Rhino and now Rhino installer did not crash at all and finished installation normally. Then I deleted also this second wineprefix and tried to run Rhino installer again with only dotnet462 installed through winetricks (so without vcrun2005 this time) to reproduce the installer crash, but installer did not crash this time at all and installed everything normally. I am not sure why, but no matter what I do now, I can’t reproduce this crash that I encountered during first installation, no matter if I have vcrun2005 installed through winetricks or if I don’t, installer always runs fine now. I just remembered that I probably installed a wine-gecko package from repositories between these installations and earlier wine was installing gecko by itself while I was creating new wineprefixes, that might have something to do with this crash, but I didn’t test it as I just realized it.
First startup of Rhino when it is asking for a license details is working as expected. If you choose a local license it will validate the key correctly and it will seem to work, but Rhino will always crash immediately after you will try to run it, so you won’t be able to use it at all. Fortunately if you will use Cloud Zoo it will work fine and won’t crash during startup. Possibly it will also work fine using license through The Zoo, but I didn’t test that, so I am not sure. I am coming from polygonal modeling software and I am not that familiar with Rhino interface just yet so I didn’t test it extensively but from what I can tell it works quite good. I didn’t find any obvious issues during my testing.
So to sum it up:
-you don’t need staging version of wine as I was suspecting yesterday, standard wine is running it fine.
-you can’t use a local license because it will crash Rhino during startup, Cloud Zoo is working though.
-it seems that installer finishes its job when it is running through terminal even when GUI crashes during VC redistributable 2005 installation
-possibly you can fix this crash installing vcrun2005 through winetricks, but it seems that the installer can just work well even without it. I just got the crash once when I was trying the installation for the first time and I wasn’t able to reproduce it again even without vcrun2005 from winetricks.
I hope this helps someone to run Rhino 6 through wine and maybe test it a little bit more extensively :).

8 Likes

I have installed Wine 5 on Ubuntu 18.04, and with Winetricks installed vcrun2005 and dotnet462. I started a new Prefix which installed Gecko, the default Prefix wouldn’t run Rhino 6 installer and just gave a blank white screen.

Running the Rhino 6 installer under the new Prefix gives the following error:- “Download and Cache Failed with error code rhino.msi:-2147023293” . According to this link this is an error with windows updating Rhino 6 update/install error rhino.msi: -2147023293 [SOLVED] . The fix is to use “The Program Install and Uninstall troubleshooter” from https://support.microsoft.com/en-us/help/17588/windows-fix-problems-that-block-programs-being-installed-or-removed . The problem is how do I run the file downloaded from this link to remove the three entries suggested?

Wow! I posted here almost 4 years ago, and the size of this thread today has blown me away.
Because I haven’t read all the posts I apologise before hand if any idea is repeated.

. The mere fact that this discussion is happening should alert people at McNeel because it means they have a product that users find it hard to replace on a Linux environment.

. It is true that market share for Linux desktops is small, but that means competition is also small. I searched online for Rhino current placement and out of 188 software packages for 3D content creation including CAD and CAE solutions, Rhino comes up in #24 with 0.42% market share.

. Trusting the above figures, Linux desktop market share is still 4x the existing market share for Win/Mac and this means an opportunity for growth, whereas Rhino market share on Win/Mac can potentially go down with new competition;
. Serious competition in Linux amounts to: Houdini, Modo, Blender, Maya, NX, FreeCAD, BricsCAD, VariCAD and only the last 4 could be considered direct competition;
. A number of solutions are already web based so they are effectively OS independent;
. Linux is community driven and if this works for Microsoft, I bet it can work for others as well;
. Even if there is Mono, .NET Core is here to stay, cross-platform and open-source.

In my case, when I change jobs, my PC with Rhino is not negotiable, no matter what the company happens to be using, but I recognise that, with more or less aggravation, I could be doing most things I do in Solidworks, Inventor, NX, Solid Edge, Creo, FreeCAD, and even AutoCAD… if it weren’t for the Rhino API.

Of course McNeel knows best when it comes to managing their products, but things change quickly in the software markets. I remember using Blender for the first time about 10-12 years ago and I’d never imagine it would compete or even surpass the industry standards, and at that point in time, I must admit:
. software for serious productivity in a professional environment on Linux was… well, complicated;
. hardware driver support was a headache;
. technical support could be a problem.

Today, all this is changing, for the desktop PC and especially for workstations. If 10-12 years ago I needed Windows to run a dozen pieces of software, now I literally only use it for Rhino… So, one never knows.

3 Likes

By the way, I tested with Wine, it works as reported, surprisingly well just minor redrawing issues…
I didn’t test it thoroughly because, well Grasshopper fails miserably!! So saaaaaaaad!!! If anyone has different luck, please let me know.

Trying to run V6 using a VM is hard if you don’t have a second GPU or Thunderbolt 3.0 support to get an external one and do PCI passthrough, since no VM i’m aware of supports OpenGL 4.0. V5 is fine though, I’ve been using it on a VM for a little over two years now

what kind of GPU do you have? Is it Nvidia one? If it is try adding this env variable:

__GL_MaxFramesAllowed=1

I don’t know which VM your’re using, but I tested on a machine with VMware and it runs fine, the only caveat being if you enable antialiasing, the viewport does not display points and control points. Everything else works as in a physical machine, though.

image

It’s a Nvidia Optimus running on the latest Ubuntu system, currently with the Intel on-board graphics active. I have installed Nvidia drivers from the repositories, but not Prime or Bumblebee.

image

The viewport redrawing issues are not critical, they disappear when reloading the viewports.

I’ve been trying to start v6 via WINE, but I can’t get past login system. When I pick login it correctly opens web browser window, but after logging in it does not go back correctly. I get “can’t establish a connection to the server at localhost:1717.” .

So you were able to install Rhino 6 in Wine? Is that with the current stable version of Wine?

yes, I’ve been able to go through install - WINE 5.7 . To make things easier I’ve used Lutris (it has also added bonus that allows me to switch wine versions easily). Can record a video howto do it in case of need.
But the the issue is I can’t validate license - can’t log in (or rather - browser window does not get me back to Rhino).

The question was rather whether the installer now works, I don’t want to waste time in figuring out how to get Rhino installed before investigating login part :slight_smile:

Also note that latest stable Wine is 5.0.1 (at this time of writing, according https://www.winehq.org/ ), development is 5.1.2. Not sure what Wine version 5.7 is…?

nope - stable is Wine 5.0.1 , while development is at 5.12 :smiley: . So 5.7 is one of the dev versions (using it as at 5.8 some regressions were introduced and haven’t checked back since).

Right, my question was whether this now installs in stable Wine. I’m not going to try and get anything bleeding edge working on my linux box.

sure, will check in 5.0.1 . I’m pretty confident that one of the stable versions will work - as I did go through install in the past, but failed afterwards.
edit: tested on WINE 5 - installer works. I simply installed vcrun packages and net (haven’t used mono) before running the installer (also checked that the font smoothing in winetricks is set to rgb) and it started correctly.

4 Likes

Can you make a tutorial video? Please :slight_smile:

5 Likes

I know this is a year after the fact, but I don’t agree with your logic. Windows has the major market share, but how many of them use Rhino? I’d say a massive group of them are content watching cat videos and playing games - not modelling.

Then look at Apple devices and you may similar user spread, but you’ll also see a disproportionately large amount of design professionals on Mac and a very large number of Linux users are coders. I remember a time, when people nearly laughed if you were a serious designer on Windows.

With Grasshopper integration as a major selling point, I would should suggest that a lot of the user-base may already be using Linux outside of work, where we rely on Windows for Rhino. This includes myself.

As for developers, that’s the same issue as with Mac, surely?

There is some hope of a Linux version even if it is very slight. In the days of v2 and v3 McNeel said they will never have a version of Rhino for any operating system other than Windows. Now there is a version for the Mac OS. If they support the program for Mac OS I wouldn’t expect it to be a major bit of work to support Linux.

I used to run Rhino v2 and v3 via Wine. When v4 came out the licencing system changed and some function call(s) used for it no longer work. All you get is a message that it was unable to contact the licence server and it doesn’t get any further.

I switched over to running Rhino v4 under Windows XP using virtualbox (currently v6.1). The only problem I have noticed is that I can’t right click the icons down the left side of the screen. Other than that one issue it works fine.

I am currently testing v7 under Windows XP using virtualbox and I have found one minor issue. In order for the viewports to appear as they normally would and for them to update quickly you must run virtual box without 3D graphics acceleration enabled in the Display settings. With graphics acceleration enabled the viewport windows will be black and can take a very long time for them to appear as normal, if they ever display as normal, which makes makes the program (almost) impossible to use properly. I have not noticed any performance issues while running Rhino using virtualbox.

The only problem I have with running v7 using virtualbox is the background bitmap images appear all white. When using v4 under virtualbox the background bitmap image is shown as expected.

Hi there, just getting in the topic.

I had to switch to Linux for professional reasons quite recently, and now I really don’t want to go back to Windows. As Rhino is the main tool I use for modelling works and CAD (and I really like its interface and everything), there’s no real equivalent on Linux and I had to find a workaround using Winapps (which is a VM in the end). It works but it’s not the ideal way (and requires power).

So, count me in if there’s some better integration coming in at some point.

Unfortunately, that is not the case. Making our code more cross-platform capable is a nice goal, but it is a very long term project just to get as much Windows and Mac code to be cross platform as possible. We’re talking years and years of work.