Rhino on Linux?

I’m getting a headache…

Are there any plans in McNeel to talk about native linux version seriously?


the fire swooshed up in an eyeblink, and extinguished even faster


I’d prefer the other way around.

… and that’s a shame. Nowadays there are ways to package things in a way that would be less tricky than in the past and I’d love to work on OS that does not try to force updates and screw me over in the middle of the project (it’s crazy how Windows is getting better and worse at the same time).

Hello everyone,

my name is Steve and on my picture you can see, that Rhino3D 7 works on my system (openSUSE Leap 15.3!

For more information: GitHub - cryinkfly/Rhino-3D---Linux-Wine-Version-: This is a project, where I give you a way to use Rhino 3D on Linux!


@cryinkfly , that looks interesting. Can you run the Rhino command _SystemInfo and post the text from that?

Also it would be interesting to see what Tools > Options > Cycles gives you - just CPU, or also CUDA?

1 Like

@nathanletwory I have published a video on my YouTube-Channel “Cryinkfly”, where you get more information about my work! :slight_smile:

Here is the link: Rhino3D (Version 7) unter Linux installieren - [DE] - YouTube

*Notice: The english version will follow soon!


That looked very promising. I’d still like to see what you get under Tools > Options > Cycles, especially if you also get to select a CUDA device (your GTX 1060).

And, since I wrote the Rhino Cycles integration, whether Raytraced viewport works for you :slight_smile:

I might try this soon also on my own Linux box, I’ll just have to get my Wine updated first.

1 Like

@nathanletwory So, I have look into the configuration and it’s so that I can’t select CUDA or OpenGL at the moment! :face_with_monocle:

But on this picture you can see, that we can use the CPU:

… and here you can see my imported STL-File:

… or the process of rendering this object:

… and I have published 3x short videos on my GitHub-Project and on one of these videos you can see that Rhino 3D rendering my imported STL-File! :smiley:


I installed winehq-devel, but I was not able to get Rhino 7.9 installed.

I used winetricks -q dotnet462 dotnet48 win10. I let the installer download the vc2005, vc2010 and vc2013 installers and installed those as the shasums in winetricks for those are incorrect.

Yet the installer fails on the check/install of the .NET 4.8 framework. Running the installer manually for the framework as downloaded by the Rhino installer end in an error message that the Windows version is not supported.

So for me this is still not functional enough unfortunately.

Oh okay I think to know why it doesn’t work for you. Then it’s so you must use the newest winetricks version and you must install also dxvk when you will install Rhino 3D without Lutris.

Then my setup with Lutris have DXVK activated! :sweat_smile:

And so you must running this command for example:

   wget https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks &&
   chmod +x winetricks &&
   WINEPREFIX=~/.rhino3d sh winetricks -q corefonts dotnet462 dotnet48 dxvk win10

I used the latest winetricks and ensured also dxvk is installed. Still the installer fails

I also tried a local build of Rhino, but that fails to start too.


Okay I see, then it’s better when you wait for my installation script. :sweat_smile::blush:

Thank you for this information! :information_source:

1 Like

I hope it will work with winehq-devel (winehq-stable would be better I guess, but I can concede to -devel :wink: )

1 Like

The stable version should actually work when the the internet connection works and you are using the latest winetricks version.

Can you go to my website to this post:

Then you must scroll down to the point “Installation and Configuration” and check whether you have installed these packages on your system?

1 Like

@cryinkfly thanks for the link. I see that for fusion you at least have msxml4 and msxml6 in use. I added these as well, but still the install fails.

I see

024c:fixme:path:parse_url failed to parse L"Microsoft.Deployment.WindowsInstaller"
024c:fixme:path:parse_url failed to parse L"System"
024c:fixme:path:parse_url failed to parse L"System.Configuration"
024c:fixme:path:parse_url failed to parse L"System.Xml"
024c:fixme:path:parse_url failed to parse L"System.Configuration"
024c:fixme:path:parse_url failed to parse L"System.Security"
024c:fixme:path:parse_url failed to parse L"System.Core"
024c:fixme:path:parse_url failed to parse L"System.Numerics"
024c:fixme:path:parse_url failed to parse L"System.Core"
024c:fixme:path:parse_url failed to parse L"MsiInstallerUtilitiesDotNet"

Maybe this gives you enough info on what verbs I potentially still need to give to winetricks


Better is when you create a log file. :blush:

I attach not one, but two log files :slight_smile:

The wine log:

wine_rhino_install.txt (22.1 KB)

And the Rhino installer log:

Rhino_7_20210722122653.txt (48.6 KB)

From the Rhino log everything appears to be going fine up until the moment the installer tries to execute rhino.msi:

[01C0:01D0][2021-07-22T12:26:59]i305: Verified acquired payload: rhino.msi at path: C:\ProgramData\Package Cache.unverified\rhino.msi, moving to: C:\ProgramData\Package Cache{FAEB7BD5-AEF9-4FAB-BE4C-EF99720507E9}v7.9.21201.13001\rhino.msi.
[01C0:01D0][2021-07-22T12:26:59]i304: Verified existing payload: rhiexec.msi at path: C:\ProgramData\Package Cache{C2EFFAD5-885B-45FF-96D2-C1D58ECD9436}v7.9.21201.13001\rhiexec.msi.
[01C0:01D0][2021-07-22T12:26:59]i304: Verified existing payload: en_lang_pack at path: C:\ProgramData\Package Cache{77DCF4F8-A27D-4351-8702-568F7E669F43}v7.9.21201.13001\redist\en-us\LanguagePack.msi.
[01C0:01C4][2021-07-22T12:26:59]i323: Registering package dependency provider: {FAEB7BD5-AEF9-4FAB-BE4C-EF99720507E9}, version: 7.9.21201.13001, package: rhino.msi
[01C0:01C4][2021-07-22T12:26:59]i301: Applying execute package: rhino.msi, action: Install, path: C:\ProgramData\Package Cache{FAEB7BD5-AEF9-4FAB-BE4C-EF99720507E9}v7.9.21201.13001\rhino.msi, arguments: ’ ARPSYSTEMCOMPONENT=“1” MSIFASTINSTALL=“7” CUSTOMER_NAME="" COMPANY_NAME="" LICENSE_KEY=“" LICENSE_METHOD="" LICENSE_VALIDATION_CODE="” ZOO_SERVER="" DEFER_NET48_REBOOT=“1” INSTALLDIR=“C:\Program Files\Rhino 7” ENABLE_AUTOMATIC_UPDATES=“1” DISABLE_INTERNET_ACCESS=“0” SEND_STATISTICS=“1”’
[01C0:01C4][2021-07-22T12:27:01]e000: Error 0x80070643: Failed to install MSI package.
[01C0:01C4][2021-07-22T12:27:01]e000: Error 0x80070643: Failed to execute MSI package.
[0120:0124][2021-07-22T12:27:01]e000: Error 0x80070643: Failed to configure per-machine MSI package.
[0120:0124][2021-07-22T12:27:01]i319: Applied execute package: rhino.msi, result: 0x80070643, restart: None
[0120:0124][2021-07-22T12:27:01]e000: Error 0x80070643: Failed to execute MSI package.
[01C0:01C4][2021-07-22T12:27:01]i318: Skipped rollback of package: rhino.msi, action: Uninstall, already: Absent
[0120:0124][2021-07-22T12:27:01]i319: Applied rollback package: rhino.msi, result: 0x0, restart: None
[01C0:01C4][2021-07-22T12:27:01]i329: Removed package dependency provider: {FAEB7BD5-AEF9-4FAB-BE4C-EF99720507E9}, package: rhino.msi
[01C0:01C4][2021-07-22T12:27:01]i351: Removing cached package: rhino.msi, from path: C:\ProgramData\Package Cache{FAEB7BD5-AEF9-4FAB-BE4C-EF99720507E9}v7.9.21201.13001
[01C0:01C4][2021-07-22T12:27:01]i372: Session end, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall{1d23d8c7-a560-4aa0-bc9e-a7fc4c64948d}, resume: None, restart: None, disable resume: No

I believe that this corresponds to the Wine error log section:


What I noticed right from the start was this error message:

… and it means that you seem to be missing the winbind package!

If you install Samba, you will also receive this package, for example. :slight_smile:

And we also have two different versions of Rhino:

  • I use: rhino_de-de_7.6.21127.19001
  • You are using: rhino_de-de_7.8.21196.05001

But I will test the new version now!

1 Like