Rhino NURBS from Torus

Hey guys,

I created a torus object in Rhino and want to save the NURBS presentation of it to an iges file. I tried several different iges formats but all export the Torus as a solid geometry. How can I force Rhino to export a NURBS surface? I achieved it myself by moving a control point because that destroys the torus definition but I don’t like this solution because I want to do this to many surfaces and I hope there is an easier way.


Hi Marcel- use TestMakeValidForV2 - does that do it?


Hey Pascal,

I’m sorry, is that a command or maybe a sample? I don’t know the name or where to look for it. :blush:


Just type the whole thing at the command line. It is a test command, it does not autocomplete, nor is it listed anywhere public.

HTH, --Mitch

This is the output:
ON_Brep::MakeValidForV2() = 1. IsValid() = 1

It didn’t do anything to the object.


If you use the What command, you see that the torus is a Surface of Revolution before running TestMakeValidForV2 and a Nurbs Surface after running it. So, the object does not change its appearance, but it does change its definition.

You’re right, it really changed the type. I had a look but maybe I was confused by the usage of TestMakeValidForV2 because it only takes one surface at a time. Still when I export it into an iges file it is recognized as a Torus. Rhino seems to be doing this as long as it can.:-/

You might want to try IGES 144. If that still doesn’t work as you want go in and edit the IGES 144 export options (make a copy perhaps) and check “split closed surfaces” and try again. Your torus will be exported as 4 open surfaces.

HTH, --Mitch

I tried both ways as you said but still I found a torus definition in the IGES. Maybe it helps if I tell you that I am using SolidEdge to open the IGES after exporting it with Rhino. The result I am expecting is that SolidEdge only recognizes a NURBS surface instead of a torus and I really, really hope that SolidEdge does not try to fit a NURBS-only IGES into a solid geometry while reading it. Thatswhy I am still searching the mistake on Rhino’s side.

It has to be SolidEdge doing something in the last case (split closed surfaces), because if you re-import the IGES into Rhino, there are 4 separate surfaces.