Rhino minimising when selecting new layout? Also strange tabs behaviour?


#1

Have been adjusting some drawings to suit a bespoke order, when I am selecting a new layout it minimises everything.


(Marlin Prowell) #2

I see that there is a problem in your screen shot, but I cannot figure out how to duplicate this. Please provide detailed directions on how to duplicate this, including your “Prefer tabs when opening documents” setting in System Preferences > Dock.


#3

@marlin Hi Marlin, I have the ‘prefer tabs’ as always in system preferences. There is definitely some strange behaviour happening with tabs, layouts etc. When I open a model if it has layouts with it they are opening automatically in a new window too, no option for tab (+ button) when the window is just a 3d model, and when I select to add a new layout page it minimises everything ?
Custom Stainless & Walnut Console (900mm).3dm (1.1 MB)


(Marlin Prowell) #4

Sorry, but I need you to be very explicit here. I cannot duplicate what you are seeing, and this is not a specific enough description for me to follow. Are you running some command, selecting a menu option, clicking some button? All these actions work correctly for me, so please be very specific in your description.

Also, what is your Rhino info? About Rhinoceros > More Info… > Copy to clipboard and then paste the results into a new post.

Thanks.


#5

@marlin
1- open a file in Rhino 5.2.3
2- click layout, it opens in a separate window
3- click the + in layout window to add a new page, this is when it minimises


#6

@marlin it’s still happening :frowning:

Software information

Software versions
Rhinoceros version: 5.2.3 (5C258)
IronPython version: 5.1.2015.131
Language: en-GB (MacOS default)
OS X version: Version 10.12.1 (Build 16B2555)

Plug-ins
None

Third party kernel extensions
None

Hardware information

Computer hardware
Hardware model: MacBookPro11,3
Processor: Intel Core i7-4870HQ CPU @ 2.50GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 750M 2048 MB
Memory: 2048 MB
Screen size: 1440 x 900
Displays: Color LCD (221dpi 2x)

USB devices
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.12.68 355.10.05.05b16
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


#7

@marlin hi Marlin, I’m not seeing the same behaviour in the WIP version, it seems to be ok ??


(Marlin Prowell) #8

Yes, the default macOS behavior of tabs does not work well in commercial Rhino. We made some changes in the Rhino WIP version and described them here. We have more changes to make after the feedback in that thread, and those changes will be in an upcoming WIP release. Once we get window tabs in Rhino working, then we will (eventually) add those changes to a future commercial Rhino release.