Rhino - Maxwell: setting light temperature (Kelvin)

I’d like to set a specific light temperature that was given to me by a light supplier in Kelvin, together with an IES file for that light. The aim is to make a physically correct render with Maxwell as a render plugin.

For this, I assume that the exact light temperature will be needed, not just a (rather arbitrary) color selection.

How can I dial in a Kelvin value in Rhino, (or from within the Maxwell-for-rhino interface)?

i use a Kelvin Hex / RGB Converter to match the colors, which you can find online. they may differ slightly in brightness i usually take the brighter ones

i believe that those values are pretty good

there is also a python script from @pascal

AddColoredLight.py (9.8 KB)

i believe i adapted most of the colors to the brighter ones

Doesn’t the IES profile handle that?

No, both .ies and .ltd seem to hold info only on luminous intensity at any specific angle ( the light profile), not color.

Thanks for the info, however I’m looking to use maxwell to replicate real life lighting. As far as I can understand, the Kelvin /RGB converters are based on interpolations and aren’t fully correct.

The maxwell manual talks about kelvin and lumen to be dialed in, though it’s not clear where to do so:
*

Lights in Maxwell Render™ are created applying an emitter material to an object. You can adjust the color and intensity of the emitter using everyday terms like watts or efficacy, or you can look into more advanced definitions using lumens, lux, Kelvin degrees, and RGB.

ic, well that is all you can do from the Rhino side as far as i can tell, for more Info you might also consider maxwell forums.

I think I have figured it out. It’s rather counterintuitive in terms of UI.

To set light color for an emitter while using an EIS file, there’s a checkbox next to “Color / Temp(K)”
If you want to control the color by RGB, then you need to check the box, if you want to dial in a Kelvin value, you need to uncheck it. The color in the Kelvin entry field changes color as you change the Kelvin value: it gets more red towards 0 and more blue towards 9000.This causes confusion, since I believed the reddish field meant that it was “off limits”.(which was the exact behavior I got when the checkbox was on).