Rhino Loads with Black Viewports. Viewports frozen when they do appear

Hello All,

Recently my Rhino6 has been loading with all viewports black. When I click on one of the dropdown menus in the upper left hand corner of the viewport the viewports will be visible. However, I am unable to zoom or navigate in any of the windows. If I zoom or navigate and click on the dropdown menu again the viewports will update, however I have to click on the dropdown menu each time to see where I’ve zoomed or navigated to. When I minimize the window and open it again, the viewports have gone black again.

I’ve looked through other topics to try and trouble shoot this issue. Most posts say to update my graphics card driver by downloading manually from the website, which I’ve done. Unfortunately, it did not fix my issue. Does anyone have any other suggestions? Here is my system info:

Rhino 6 SR29 2020-8-25 (Rhino 6, 6.29.20238.11501, Git hash:master @ 06b936ae4e8c289ecccfd6b5ee9bacccc60eded1)
License type: Commercial, build 2020-08-25
License details: Cloud Zoo. In use by: Alexander Poh ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: LAPTOP-8PKOG883

Hybrid graphics system.
Primary display: Intel® HD Graphics 530 (Intel) Memory: 1GB, Driver date: 6-2-2017 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 980M (NVidia) Memory: 4GB, Driver date: 11-6-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 457.30

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-6-2020
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

try this-

Your intel driver is still old… you will likely want to update that straight from the intel site, as the windows driver updater has almost 100% false report rate.
(google intel graphics drivers)

When you updated your nvidia, did you use the advanced, or custom option and then used the “clean install” option? If not, please redo the install and use the custom or advanced option and use the “clean install” option.

Also make sure your windows install is FULLY updated. run windows update, you may need to run it several times. I had one customer who had to run it 9 times…

if none of this works… call tech and we’ll dig into this deeper, we definitely don’t want you unable to work.

Hi Kyle,

Thanks for getting back to me. Unfortunately I’m still having the same issue after running through your suggestions. Below is a summary of what I’ve done and a couple of complications that may be at the source of the continued problem. Thanks again for spending the time to help me with this. Much appreciated.

I redid the update for Nvidia and ran a clean install. I also followed instructions in the link regarding optimizing Rhino Performance and NVIDIA Performance. (By the way, I love the title of the link you referenced inside the article haha, wish I had read that article before buying this laptop!)

I’ve also updated my intel driver through their Driver Support Assistance which says that my driver is currently up to date. However, when I check my system information in Rhino it still lists the old driver. I tried downloading the driver directly from the website, but when I run the install it says that the manufacturer of my computer created a custom driver and that I need to contact them. I looked at Asis’s driver updates page and they are still listing the 2017 driver as the latest update.

there is a way to get around the custom drivers, and that may be part of the issue.

check this article-