Rhino kills my internet connection

Make and model of computer? If laptop are you running on battery or with power brick connected?

MSI GS66, i9-10980hk, RTX-2080s Max-Q, 32GB Ram.
Always running on power brick connected, checked in both BALANCED and PERFORMANCE mode.

Quickly googling “MSI GS66 wifi issues” returns various problems with the wifi on this laptop (like running games stopping the wifi - great for a gaming laptop!).

Things to try based on what’s out there: Turn off the Killer features and/or remove the Killer s/w. Replace the drivers with appropriate Intel ones if possible. Run wi-fi on the 2.4 band, not the 5 and/or change the wifi channel on the router.

A more thorough search may turn up further ideas.

If other people have this problem it would be helpful if they post their computer details. Conversely, if anyone has the same computer but does not have problems an exchange of configuration details may help nail this.

Cheers
Jeremy

1 Like

Fortunately, my laptop does not have the WiFi issues you mentioned, even under heavy loads in 3ds Max and Vray renderings.
I called the MSI service centre and they asked me to change these settings in the NVIDIA Control Panel and it worked for me:

  • Preferred graphic processor: High-Performance NVIDIA Processor
  • Threaded optimization: ON

The problem seems to be from the Nvidia graphics card driver settings, which will be fixed by changing these settings!

3 Likes

Thank you so much!! it seems to have solved the problem for now, been wondering what was causing the wifi issue and restarting routers

Hi all, I have a new MSI GF63 Thin 9SC laptop and was having this same issue after installing the Rhino 7 evaluation version. I tried all the suggestions in this thread and nothing worked. After much searching through online forums and a 1.5hr call with MSI service center, I have found a solution that works for my laptop. Initially I was connected to a dual band network while trying to run Rhino and was connected to the 5 GHz band which was causing the connection issues. Changing to the 2.4 GHz band is the fix.

*Open Device Manager
*Open the Properties for your wireless driver under Network Adapters - mine is Intel(R) Wireless-AC 9560 160MHz
*Go to the Advanced tab
*Scroll down to Preferred Band and select “Prefer 2.4GHz band” from the drop down menu

You may need to restart the device for the change to take effect. Mine immediately switched to the 2.4 GHz band and then when I opened Rhino the wifi connection remained stable.

The post by [michal.tofik.olszewski] on this MSI forum had the solution:
https://forum-en.msi.com/index.php?threads/wifi-turn-off-or-goes-very-low-every-time-i-play-a-game.311977/

Hope this helps!

A post was split to a new topic: Pollination plugin expired