Rhino is smudging my diamonds, why? [Flat shade doesn't work]

The above image is a diamond mesh as it is in Zbrush.
But when the mesh is OBJ-ed to Rhino Beta, [bellow image] it is all smooth and smudged
the mesh hasn’t been modified, one can see that it is exactly the same.
But in Rhino there’s this terrible smoothing thing that messed up the mesh
Flat shading [in display] appear not to work at all…?
It used to remove that unwanted smoothing in Rhino 7

Now what …? how does one render a smudged diamond?

With hope for a quick solution… please

thanks a lot
akash

Unweld (Angle=0)… ?

What happens if you ShrinkWrap it?

Thanks @Helvetosaur
Unfortunately It’s a bug in the Beta, not something that needs to be solved on the level of the mesh object.
The option in the Display panel : Flat Shade is not working.

This is most evident with the diamonds [as in the pictures] but it also mess all the other mesh objects I have sculpted [in ZB] hi res objects in this model. They are intentionally sculpted to give the un-perfect hand finish feel to the jewellery. And in Rhino Beta, they are being smoothed , killing the subtle roughness , and creating unwanted display effects [where rhino has hard time with the smoothing art affect it is doing!

*The main part is about 13 mil faces…… doing any modifications to it in Rhino. ….is a nonstarter.
Just selecting that mesh take about 30 seconds. [an unrelated issue of selecting bid meshes that has been sadly dropped from Rhino 8 ]

@Akash can you send me the obj? Does it open correctly in v7?

Hi @Gijs

this is not a specific obj, any obj I import from Zbrush is smoothed, the Flat shading Dows not work.
I don’t have 7 installed, but this always worked correctly from R5 -R7
[* these diamonds originate as Rhino nurbs]
does flat shading work on your side? [in Beta]

here’s one diamond

smaged Daimonds_for Gijs.3dm (3.6 MB)

the smoothing is visible also on the main part, it’s less obvious as it is not a faceted gem, but still it kill the roughness that I sculpted intentionally.

thanks a lot
Akash

check the normals
_dir

did you try _unweld as @Helvetosaur has suggested ?

if you want “visually” sharp edges, you need 2 vertices at the same position, that will have 2 normals.
with welded Edges you will only have one normal.

but well the box in the middle gets visually sharp if I turn on Flat Shade… :thinking: … not sure…

@Akash
please share a file - you can also export something odd that shows the problem.

1 Like

thank you @Tom_P
Unweld will do the trick, but I’m not going to do that, this is what Flat shade is for… it has been working correctly for all previous version of Mac Rhino…
so it’s either a bug or something in my copy of the Beta, [I noticed this months ago… but it didn’t click at the time… [I used Nurbs diamonds as a fix, but it is not possible in this model]

[a file is attached to my previous post.]

@Akash thanks for reporting, this seems indeed broken in v8 when Metal is used
RH-77946 FlatShade doesn’t work on Mac in v8

That being said, this mesh should not come in welded if the source isn’t welded. So either this is a setting in ZBrush that you need to tweak, or this is a bug in their exporter.

the Mesh is closed and welded in ZB, the mentioning of unwelding as a solution was proposed by @Helvetosaur and @Tom_P
I only work with welded closed meshes [as they usually go for printing … and in addition, many operation in ZB get messed up with unwelded meshes]

thanks a lot for the bug report.
I hope it is solved soon, as I’m fully stuck here without the flat-shade.

The only workaround I have for now is _TestMetal, but it will probably also kill your display performance.

Yes I don’t dare to turn Metal off.
Just guessing [need to test] But since I’ll eventually do the final renders in Bella [once I manage to learn how to… well enough.
Then perhaps the flat shade /smoothing thing is not problem in Bella’s external renderer…?

Not really sure what you are looking for, but you could try the Bella “Preview” mode in the viewport. That is much faster than using the full rendering mode. For many geometries, I find it very helpful, for just seeing texture deployment.

No idea if it will work.

I highly doubt it, Rhino render will not look at flat shade AFAIK. So if your goal is rendering, then you will have to provide the renderer proper meshes anyhow.

as Gijs says, bella will render the meshes as given, however you can override this – here is a chamfered cube welded with 90 degrees, but then forced to render with flat normals

Thank you all

I did a simple test just now.

  1. inserted a NURBS Diamond

  2. exported as obj and re imported back to rhino. the mesh is good faceted with no smoothing.

  3. imported the obj mesh into zbrush, and re export it, and imported back to rhino. The mesh is good faceted with no smoothing.

  4. Then as @Helvetosaur suggested unweld (Angle 0) fixes the smudged diamonds. Thank you!

So I guess something happened to damage the diamonds while in ZB… Perhaps the Boolean [they were used to cut the seats] but were not modified in themself…

Q: is it a good idea to add unweld (Angle 0) to the import macro?
*I don’t actually understand what it does?

thanks a lot