Rhino is inherently bad at handling meshes true or false?

‘Rhino is not responding’ this after one mesh imported and is declared during save v7

:frowning: Steve,
I am using V7 as I am told its far better at meshes, a Rhino weakpoint before then.

I have a new file, import the mesh, move it etc, do a save and rotating blue ring appears, and then ‘Rhino not responding’ it says, but then after 20 or so secs, that goes.

This is a new PC built for Rhino to handle meshes !
GTX 3070
64Gb DDR4 vengeance pro memory
AMD Ryzen 7 5700X 8-Core Processor 3.40 GHz
Asrock Mbd
all SSD drives.

This should not treat a mesh as if it were V5 anymore.

I will be working with meshes and threw all I had at this PC.
This PC and V7 is where my futire lies…

and Rhino V7 is seemingly as poor as V5 at handling meshes. All my hopes …:frowning:

Am I right in saying Rhino is no good at handling meshes,

Perhaps Holo could do a mesh tester ?
@Holo

I will run Holo’s test when I get 5 mins here.
Lost half a day to V7 so far.

Steve

Hi Steve, that should be a great machine. Can you describe in detail what you mean with meshes? Amount, number of polys etc. and send me a file so I can compare?

The ring appears when saving? Or when rotating the view?
How big is the mesh/file?

Hi,
Blue ring is when saving file, all thats in it is new space and the mesh, and I drew a circle and three or four lines.

How do I find out the data for the mesh you need ?

Hi Holo, how do I send the mesh, I use wetransfer unless McNeel has a confidential upload thing.

This is not for public consumption.

selecting the mesh, properties in V7 says:-
Geometry:
Valid mesh.
Open double precision polygon mesh: 2254779 vertices, 4264340 faces
Bounding box: (-2.19883,-1.17199,-4.81476) to (3.26494,3.02819,-0.392466)

What else can I get using V7 ?
It has a .jpg textured to it. 1920x1200 459Kb
obj is 387Mb

Steve

Wetransfer is great, I don’t have access to McNeels servers. You can send it in pm and I’ll test it.

Turn off file compression when saving. It’s in Options > Advanced, type “compression” in the search box and you will find it. Set it to False and try saving agin and see if it saves faster.

1 Like

Hi,
found it, was true, set to false, save and 1 sec, was 30 sec !

repeat save 1 sec was 30secs.

this needs flagging up. strewth what a difference.

Anything else I should know about, to make V7 kind ?

(my dims issue crying out for help, scale was 10, make 1, no keep as 10, but dims can’t see, still the barrier to starting V7)

Hope to solve this before needing to put dims into this mesh. else V5 here I come again.

In fact I am about to add dims and syill havent a clue on that model space scale and the text gap issue.

Now why is compression set to true if it takes forever to do.

what is the result, is rhe file type going to be huge ? seems to be same size.

I am running out of space on D drive with all this photogrammetry !

Holo, sending via wetransfer., need your email to do so, but cannot locate it.
Can you PM me with it ?

Steve

Use a link instead of an email address and send the link via the PM function of the forum.

This is a known issue and it’s not going to be fixed in V7.