Rhino Inside Revit Sample Files Missing (Revit to Rhino)

Hi - does anyone have a copy of the sample files shared on the McNeel Wiki? The link no longer works for the Revit into Rhino files and I can’t see what the Python component script entails. Thank you!

Here is the main page for that tutorial. The samples files are here too: https://www.rhino3d.com/inside/revit/beta/samples/transfer-revit-to-rhino

1 Like

Thank you!! :smiley:

Hi Scott, can you let us know where the files has been relocated to now? link isn’t working.

Update: found them - https://www.rhino3d.com/inside/revit/beta/discover/?keyword=kind:%20example
Thanks again for the amazing developments


Hi all,

Having issue with the sample file, can anyone help?

Not overly experienced in Grasshopper but the part of the script in the sample file is appearing as a white box and when I press the button to get geometry into Rhino the baker turns red and no geometry can be found in rhino…

Any ideas?

The sample files are meant for use in Rhino Inside Revit - you can’t run through these files using Rhino standalone. You will need to launch Revit then launch Rhino Inside then open Grasshopper within that space.


Hi Channing,

Thanks for the reply.

This is launching Rhino 7 inside revit and not standalone… strange.

Still havent found a solution - tried uninstalling and reinstalling as a simple remedy but alas it hasn’t worked!

just to confirm, you’re launching Rhino/Grasshopper from Revit, and there’s a proper component where the white box is in your previous screenshot?

If you’re clicking the button while the white box is there, of course you’d get an error, the white box is a placeholder telling you you’re missing a component, it doesn’t output any data to the Python script

If there is a proper component, chances some code has been changed and that Python script is out-of-date