Rhino Inside Revit Plugin Debug issue

Hi,

I’m trying to build a plugin to exchange Karamba models to Revit whilst running inside.
I’m having troubles when trying to execute whilst Debugging from visual studio.
I can debug other plugins, and have no issues when starting Revit manually.
One identified difference is that the other plugins are compiled in configuration “Any CPU” whilst the Karamba is 64 bit (I can’t get it to compile as Any CPU).

The error messages in Rhino I get whilst grasshopper loads Karamba is

  • Loading karamba assembly…
    An error occured during GHA assembly loading:
    Path: C:\Program Files\Rhino 7 WIP\Plug-ins\karamba.gha
    Exception System.MissingMethodException:
    Message: Method not found: ‘Rhino.Geometry.BoundingBox Grasshopper.Kernel.IGH_PreviewData.get_ClippingBox()’.

Any suggestions on how to get debugging working?

Thanks,

Jon

Hi Jon,

Have you tried to debug it when Rhino is not loaded inside Revit?
Since you tell that it works without problem when you start Revit manually have you tried to Attach de debugger after loading Karamba?

Please share what you found.

Hi Kike,

I should have thought of attaching the debugger to the process, that’s a great suggestion and it does work.

I did try building the other plugin in 64 bit and it did debug correctly, so not sure what the issue is.
Thanks again for your suggestion.