Rhino.Inside.Revit - Issues with the Grasshopper window on dual monitors

Hi, I’m just getting started with Rhino.Inside.Revit and I noticed that the Grasshopper window moves when I pick an element in Revit 2023. I’m using RhinoInside.Revit_1.7.8194.7007. Whenever I have this window open on my second monitor, it retains its position correctly.

This is on Windows 10.0.19044

Also, when I want to open another Grasshopper document, this dropdown window also opens on my second monitor, which does not happen with Grasshopper that’s not run inside Revit. The monitor’s border is at the right of the Rhino and Grasshopper window in this screenshot.

Hi Intuos,

Hopefully we can get some additional feedback from people who use multiple monitors. I’ve only used grasshopper on one, due to the nature of the workflow of only one window active while being in 3 programs at once.

Can you post your system info? Type systeminfo in the command line and paste here. Key things here are your multiple screen alignment and resolutions.

One thing that may also be a factor is this option in Rhino.Inside.Revit

I have the same settings as you posted.

Here’s my system info:
Sysinfo.txt (2.4 KB)

Any error message baloons that pop-up inside Grasshopper also show on my secondary monitor, instead of being moved to the left on my main monitor.

How are your monitors scaled? Aligned?

Like this:



Both are 4k.

Best results are when the scaling is matching, the alignment looks fine. Try both at 100% scaling.

1 Like

Thing is, one is a 15,6 inch laptop screen and the other 27 inch, so that will be difficult to read on the laptop screen :upside_down_face:

I had this issue where all keyboard shortcuts including DEL wouldn’t work when using dual screen with the laptop. Adjusting to 100% fixed the issue. thanks