Rhino inside Revit - crash on copying/saving baked objects

Hi all, I’ve experienced some weird rhino/revit crashes when i try save/copy objects in rhino coming from revit->grasshopper.

The case is as follows:
I target objects from revit using rhino inside revit ( this could be a curve from a room boundary or a brep of a window mullion).

Bake to rhino from gh works fine

As soon as i try to save/autosave rhino OR select my objects and ctrl+c copy, then rhino and revit and the whole stack dies.

Seems like Rhino inside revit has added something to my objects that cause the crash.

Workaround for now has been to internalize those objects in the grasshopper file, open up “pure” Rhino (without the RiR hook) and then baking them. This has worked fine.

No clue whats causing the crash though, if its some userdata or similar…

Hi Mathias, I changed to the Rhino.inside.Revit forum category.

This is something you are scripting? Can you provide more info? This isn’t something i’ve seen before.

Hi Japhy thanks,

It happened both in Revit 2022 and 2023.
See GIF below. also attaching GH files. It’s as soon as the object serializes for (auto)saving/exporting/copying. It might be another plugin causing this?.

Sometimes i get the rhino popup crash other times the stack is just killed.

Same breps are nicely baked and saved in another non-RiR instance of Rhino.
rir crash
breps.gh (3.2 MB)
breps_frames.gh (24.9 KB)

Thanks, I’ll take a look.

Can you run SystemInfo in your Rhino command line and paste the results here?

Just was “lucky” to get this one. Might you be able to pick out some info from that ?

Btw just updated RiR , didnt solve it.

Rhino 7 SR28 2023-2-10 (Rhino 7, 7.28.23041.13001, Git hash:master @ 78b4312dc75e2b5005bc7cc69a35c7cf10e4970e)
License type: Commercial, build 2023-02-10
License details: LAN Zoo Network Node

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 64Gb)

Computer platform: LAPTOP  - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
  Primary display and OpenGL: NVIDIA Quadro P1000 (NVidia) Memory: 4GB, Driver date: 9-12-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 517.40
    > Integrated accelerated graphics device with 4 adapter port(s)
        - Windows Main Display is laptop's integrated screen or built-in port
        - Secondary monitor attached to adapter port #1

Secondary graphics devices.
  Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 2-18-2021 (M-D-Y).
    > Integrated graphics device with 3 adapter port(s)
        - There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  Graphics level being used: OpenGL 4.6 (primary GPU's maximum)
  
  Anti-alias mode: 4x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: High
  
  Vendor Name: NVIDIA Corporation
  Render version: 4.6
  Shading Language: 4.60 NVIDIA
  Driver Date: 9-12-2022
  Driver Version: 31.0.15.1740
  Maximum Texture size: 32768 x 32768
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 32768 x 32768
  Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
  C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\Modelur.Windows (ad2483aa-a880-4b0d-b6e5-2ac16f572543)\2021.6.1.0\Modelur.Windows.rhp	"Modelur.Windows"	2021.6.1.0
  C:\Users\mm1013\Documents\RhinoPlugins\ElefrontProperties.rhp	"ElefrontProperties"	1.0.0.0
  C:\Users\mm1013\Documents\BlockEditNew.rhp	"BlockEdit"	1.0.0.0
  C:\Users\mm1013\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\ggRhinoIFC\2.1.22.0\ggRhinoIFC.rhp	"ggRhinoIFC"	2.1.22.0
  C:\ProgramData\McNeel\Rhinoceros\packages\7.0\LadybugTools\1.36.144\Ladybug.RH.Loader.rhp	"Ladybug.RH.Loader"	1.36.144.0
  C:\ProgramData\McNeel\Rhinoceros\packages\7.0\Pollination\1.8.1\Pollination.RH.Loader.rhp	"Pollination.RH.Loader"	1.8.1.0

Rhino plugins that ship with Rhino
  C:\Program Files\Rhino 7\Plug-ins\Commands.rhp	"Commands"	7.28.23041.13001
  C:\Program Files\Rhino 7\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp	"Rhino Render"	7.28.23041.13001
  C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	7.28.23041.13001
  C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
  C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp	"IronPython"	7.28.23041.13001
  C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	7.28.23041.13001
  C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	7.28.23041.13001
  C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
  C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp	"Displacement"	


Quick update, disabled plugins, all except

  C:\Users\mm1013\Documents\RhinoPlugins\ElefrontProperties.rhp	"ElefrontProperties"	1.0.0.0
  C:\Users\mm1013\Documents\BlockEditNew.rhp	"BlockEdit"	1.0.0.0
  C:\Users\mm1013\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\ggRhinoIFC\2.1.22.0\ggRhinoIFC.rhp	"ggRhinoIFC"	2.1.22.0
  C:\ProgramData\McNeel\Rhinoceros\packages\7.0\LadybugTools\1.36.144\Ladybug.RH.Loader.rhp	"Ladybug.RH.Loader"	1.36.144.0

so now it works. I can debug my way through the other plugins to find the guilty one.

1 Like

Looks like it’s the Modelur plugin. Which I don’t need for now so it’s all good.

Thanks for the update. That plugin looks to be actively being developed. I’ll send their devs a note.