Rhino.Inside Not loading with VRay for Revit

I found an issue with Rhino Inside not loading while have the latest version of VRay for Revit installed.
I recieved the -200 Error Message

image

I then went through all of my add in’s and was able to pin it to VRay.

Here are the version of Rhino.Inside, Rhino and Revit
image

Here is the latest version of VRay

image

I disabled the Vray Add In and Rhino.Inside will Launch

Thanks for reporting.

We will need to test this here to found a solution.

Hello @cgrammens I downloaded and tested the latest Vray (hotfix4) for Revit and confirmed the issue. The problem is the Xceed.Wpf.Toolkit.dll conflict between Rhino and Vray. Go to the VRay install directory please (C:\Program Files\Chaos Group\V-Ray\V-Ray for Revit) and rename Xceed.Wpf.Toolkit.dll to Xceed.Wpf.Toolkit.dll.bak

Then load Revit again and RIR should load graciously :smiley:

Thx @eirannejad
FWIW I did receive the message below after renaming the .dll. I am able to load both Rhino.Inside and VRay as you indicated above. VRay seems to work but I am not sure if any it is missing any functionality. I am still learning VRay for Revit.

1 Like

Okay we’ll work on figuring out a proper solution. This is just a workaround for now :smiley:

I figure it was a work around. At least you can use both programs with your option. I was having to disable VRay in order to get Rhino.Inside to launch.

1 Like

There is a new release (v0.8) at ‘Daily Channel’ to fix this problem.
Anybody may confirm us it is fixed on his side?

Thanks.

1 Like

Confirmed. v0.8 resolves the issue.