Rhino in chinese after fresh install


#1

Hi,

I´m trying to install the latest version of rhino in our lab.
but after i install it, it will come up in chinese. (supposed to be in US English)
i´m installing from rh50_en-us_5.9.40617.14345.exe
Rhino is set to use the zoo server (so i can not even get to the language preferences in the program, as i´m also facing troubles with the zoo)
Also, the computers´s locale is set to Icelandic.

Kv,


(John Brock) #2

HI
My guess is when the installer ran, one of the components it runs is:
C:\ProgramData\McNeel\Rhinoceros\5.0\Packages\localization (en-us).rhi

Close Rhino, open the Windows file Explorer, and browse to that folder. Right-mouse click on the localization (en-us).rhi file and choose Open with Rhino installer engine. See if that gets you sorted.

Good luck


(John Brock) #3

If that localization (en-us).rhi file isn’t there, please let us know.

@brian and I would like to see if we can figure out what might be going wrong.

Thanks


#4

I managed to solve the problem by installing the English language pack after installing the program(32 and 64 bit) itself.

I installed the program by running the english msi from within the installation directory (I unpacked rh50_en-us_5.9.40617.14345.exe). (i use an adapted setup.ini)
After the installer completes i install the english language pack (msi from the same folder).

i have not checked if the rhi-file was there or not.


(John Brock) #5

In you ‘manually’ install Rhino V5, there are actually 4 different MSI files to run:
rhino5setup_en-us_x86.msi
rhino5setup_en-us_x64.msi
LanguagePack_en-us.msi
HelpMedia.msi


#6

thanks, installing these files in order was a breeze.

one thing though.
even though the setup.ini file stated that it was to get the license from the zoo, this was not reflected in the setup-procedure.
(i had to manually select that the license was to come from the network.)
the zoo-server was correctly taken from the setup.ini file however.


(John Brock) #7

Can you post a copy of the setup.ini file you used?
If all the options are set correctly, it should work fine.
It works here for me.