Rhino hatches not associative with boundary

Hi there,
I am hatching polygons in rhino and i want to make them associative to the boundary- as per the rhino instructions Im turning history on (record- yes and update-yes) but once I have done the hatch and then edit the polygon boundary the hatch just disappears!
any ideas?

That doesn’t happen when I try that here. Could you post the file and your GPU information (a screen shot of Rhino Options > View > OpenGL)

thanks Wum, files attached- your help is much appreciated. jules

170302_rhino for windows forum_base.3dm (834.1 KB)

How are you “editing” the hatch boundary? Things that may break the history and make the hatch disappear:

  • Moving an element so that the boundary is no longer closed
  • Deleting an element that composes the boundary
  • Splitting or otherwise modifying a boundary element so that its object ID (what Rhino uses to concoct History) changes

Can you post an example with a history-enabled hatch and an editing routine that makes the hatch disappear?


Hi Jules,

On an unrelated note: you might want to update your GPU driver, it’s dated 9-12-2014.


Also make sure to check for Rhino updates.

hi mitch/ wim

I have just tried this on my home (not work) computer and it worked fine- so obviously it a problem with my work computer…I will try updating it and see how I go.

thanks for your help and apologies for the slow reply (been away…)



I’m having the same problem is there an official solution to this thing?