Rhino hangs for a few seconds (unresponsive) and comes back

Since installing rhino 5 x64 SR 10 (were there 2 with the same number?) I have this very annoying issue where rhino will become unresponsive during rendering in Vray for Rhino for a few seconds and then come back. This can happen several times during a rendering and the complexity of the scene doesn’t make much of a difference. Older files I know that were rendering correctly show the exact same issue. I want to check if I can resolve this issue by going back to previous SR (8 or 9, don’t know for sure) but these installers are no longer on my system. I tried everything I could think of, all sorts of hardware checks, but nothing seems to be helping. Even going back to earlier Vray versions that I am sure were working correctly doesn’t solve the issue I’m having.

Is it possible to download previous SR somewhere?

thanks in advance,

Hi Gijs- look in here:


there are some cryptically named folders in here with recent installers buried inside.


thanks. The only two that are in that folder are:


Which versions are that?

I’ve installed the previous, but that is also a SR10 and it doesn’t solve the issue unfortunately. So is there a way to obtain SR9 otherwise? Because I don’t have it in my download cache.


Hi Gijs,

I have the exact same issue and have not yet found a solution. How did you go with it?

My computer should be able to handle it fine (2 x xeon 6 core processors and 64gig RAM with 2 x SSD’s), there is no hardware reason for this to be happening. As you experienced, it happens under all circumstances on my PC. Oddly enough this isn’t an issue on my older much less powerful PC (running the same exact same version of Vray, Rhino and windows software).

Any one else have any thoughts solutions?

@Louis_Ryko, see if this helps and make sure VRay is updated to the most recent version.


Thanks for the reply @clement but thats not the issue. (I have actually applied this fix for that specific problem also)

The problem I refer to specifically is in the rendering process. The buckets stop moving (though are still visible) and when I try to scroll, pan or interact with vray/rhino at all the screen becomes grey (like a usual unresponsive program in windows). After a few seconds it comes back to life, the buckets resume moving (they don’t jump, as if they have been calculating in during the frozen time) and all is normal.

This can happen anywhere from 1-10 times during the render. It’s not catastrophic but it does slow down my rendering time and lag my production.

Any other thoughts well appreciated!

Hi Louis,

Unfortunately I haven’t found a solution yet. Thing is, it doesn’t happen all the time, and it doesn’t even happen in the same file the same way.
Does it happen with you all the time each and every file?

Just an idea, but it sounds to me as if Rhino is doing something in the background, autosaving for example.
Have you checked the “Batch Render”-checkbox in vray? If not you might give it a try.
It should prevent Rhino from interfering and it might (or might not) help. :wink:

It seems to be fairly regular, but I guess it’s not 100% of the time. I can’t find a pattern and testing possible triggers is hard as I it doesn’t happen every time.

What are your PC specs? Perhaps it is a hardware issue?

Additional to the above list I use a nvidia quadro k2200 GPU.

@deis, interesting you say that. I’m fairly sure that it’s not the autosaving (as I witness this happen also) but the way vray/rhino freezes up during an autosave is very similar to the problem described.

Intel® CoreTM i7-3930K 3,2GHz Hexacore
Kingston HyperX 16 GB DDR3-1600
Quadro 4000
OS win 7 64 running on Intel SSD 120GB, 520 Series in RAID0

Then I have 3 similar system as render nodes

It’s a difficult issue to track down because it is not repeatable. But
normally when I render previews, I’m doing it in a Rhino viewport with Vray
RT, and then for the final res, I am not watching the render process, so it
might happen a bit more often then I know. But what I did notice is that
the issue often happens when switching to the render process during

If you are rendering only on your system without render nodes, you could
try if it makes a difference to give Rhino not all the resources it can get
by using task manager, right click the Rhino process and use set affinity,
uncheck 1 or more logical cores and see what happens. If you use render
nodes though, it will not fully use them either, so for me it is no option.

I haven’t tried to check batch render because it blocks rhino during
render, but it is an interesting thing to try to see if it makes any
difference, did you already test this?

btw sometimes the buckets freeze and continue where they stopped, but
sometimes I do see them jumping, as if only the displaying of the render
process had been frozen.