Rhino Fullscreen on second Screen not Working


#1

Dear all,

I am running Rhino 5.0 on a P50 Workstation, Windows 10 with a M2000M graphic card and eveyrthing is fine as long as I don’t try to make Rhino fullscreen on an external display, than the complete Viewport is black. Drivers where updatet 2.17.2017 and are the newest from lenovo. This happens via Thunderbolt as well as via HDMI on different Screens / projectors… and only when extening the Screen not when duplicating…

Grasshopper does work fullscreen on the second screen.

This is a little fustrating for such a laptop. Any suggestions.f


(Nathan 'jesterKing' Letwory) #2

Out of interest, does that happen also with Rhino WIP?

/Nathan


(Pascal Golay) #3

Hi Richard - I’ve never heard of this one… does the rest of the Rhino main window look correct (frame, UI elements) , and only the viewport is black? Is your machine set up to Extend the desktop over the two screens or duplicate?

-Pascal


#4

Screen is set to extend and it is the complete Rhino Viewport that turns black.


(Pascal Golay) #5

Hi Richard - thanks. Hm. I do not have a good idea at all. Has this ever worked right on this machine? What is the exact Windows 10 version ? Is it 1703 by any chance?
(Help > About this PC)

-Pascal


#6

No it has never worked, its kind of brand new… Windows version is 1607?


#7

Me too! I have a similar problem although I think it is related to the two graphics cards. I normally work with my laptop screen and two external monitors via the docking station. If I have Rhino maximised on the laptop screen then snap it (maximised) to an external monitor, the display ports go black. I can fix this by moving it back to the laptop screen (this fixes the display port), “restoring down” the window, dragging it so that it is spread over both the laptop screen and an external monitor, releasing the mouse, then dragging it completely onto the external monitor and maximising it. It should be noted though that I have had this happen with some other programs as well (SourceTree is a big offender) so I think it may be driver related.

I think that when you are connected to an external monitor and you open rhino on the laptop screen, it opens using the intel graphics card whilst the external monitors are using the NVIDIA. The drivers don’t seem to deal with the hand off too well.

This has been happening before and after the Creators update.

@richard_schaffranek are you able to see which graphics card rhino is using? try opening the NVIDIA control panel and see if it has a rhino profile.


#8

Hmm, ya I figured that out today after installing Autodesk Inventor, same problem.

I guess you are right it must have something to do with switching between graphic cards… I am not sure what to do, I was in line with Lenovo today and they told me to reinstall Windows … What a nice joke…

Somehow I feel a bit annoyed by that …

@wattzie are you running the same configuration as me?


#9

Yes it happens With WIP too, but I guess it has nothing to do with rhino but with drivers in Lenovo ThinkPad.

See bottom…

Sorry Richard


#10

It seems like it is similar.

I have read somewhere that you can disable the intel graphics card in the BIOS somewhere however this will have an impact on battery life. It seems like my problem is not as pronounced as yours, I can still get rhino to run maximised on my external monitors with the workaround above so I can live with it as is.

Are you able to open rhino directly on your external monitor so it never touches the laptop display?


(Nathan 'jesterKing' Letwory) #11

When external display is attached it probably helps to make it the primary display. That should ensure Rhino using the GPU the external display is attached to. That could help. Let me know.

/Nathan


#12

I have updated to Creator release, this fixes it for Rhino but not for Inventor confused…

However I guess I have to start calling Lenovo, they should get their drivers fixed. I mean this is not magic…

You shouldn’t be doing some kind of voodoo magic when to get your workstation working for that kind of money…

That is the crappy side of PC …

thanks for th ehelp


#13

Yeah I have been trying to recreate this this morning but have not been successful. I recently applied the creators update so this could have fixed it but I cant be certain. I will update this if I notice it again.

The update did not fix the same problem with source tree, I am surprised this program bugs out with the GPU. Its not like it is that complex, certainly not a CAD program. Perhaps this is another issue entirely…