Rhino Exports Tube as Box When Choosing STL

When exporting a tube (i.e. closed extrusion) as STL with the following settings:

Density 0.0
Maximum angle 0.0
Maximum aspect ratio 6.0
Minimum edge length 0.01
Maximum edge length 0.0
Maximum distance, edge to surface 0.0
Minimum initial grid quads 0

And check Refine mesh and Pack Textures.

I have a very simple .3dm file that can reproduce this problem, but can’t figure out how to upload it and attach it to this post.

Update: I’m running Rhino for Windows, 5.14.522.8390

Yes it could do that very easily, simplify a tube into a box, those mesh settings are very “loose.” Try at least setting the maximum distance to some sort of tolerance that’s appropriate for the scale of your object and the 3D printing technology.