Rhino creating 2 caps for one solid?


#1

when I try to cap one solid object it creates 2 caps resulting in one closed polysurface. This makes the one extruded object have several lines on it, as if it has been divided in different sections yet when i click on it, it is one solid/polysurface. Why does it do this? How can I cap an object so that it results in one cap? instead of two.


#2

When you use Cap, Rhino will attempt to close ALL planar openings in the selected object(s). If you are seeing two caps being reported when you think there should only be one, it is possible that you have a micro opening that you did not notice that got capped at the same time.

Undo with Cmd+Z and then call DupBorder on the object (or show naked edges) to see where the object is open.

If you are looking for a selective Cap function that allows you to pick which holes to be capped in an object, that does not (yet) exist in Rhino - although it might be something interesting to add.

–Mitch


(Wim Dekeyser) #3

I’m reading this differently but not 100% sure.
It sounds like you extruded a curve with solid turned off. That way you would get two open ends and cap closes both. What happens then explains what you are seeing : the extrusion (a special type of light-weight object in Rhino) gets turned into a regular polysurface (which can, but doesn’t have to be a solid). Extrusions are displayed without isocurves whereas regular objects by default have them turned on. You can turn them off in your display mode. Extrusions also have a special vertex snap.


#4

Yeah, maybe, it’s not all that clear to me, thanks. --Mitch