Rhino crashing on Windows 11

Hi,
Rhino V7 & V8 are crashing when I use splash screen to open a file at startup.
This started occurring after a windows 11 update a couple of weeks back.
I’ve sent in the rhino crash reports.
I’ve completed a clean reinstall of nvidia drivers.

What’s the next step to sort out?

Below is the system info.

Rhino 8 SR6 2024-4-10 (Rhino 8, 8.6.24101.05001, Git hash:master @ 32c244aa711e0034e75bec2e87d093c764820b96)
License type: Commercial, build 2024-04-10
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [80% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 4080 Laptop GPU (NVidia) Memory: 12GB, Driver date: 4-2-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.12
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 4080 Laptop GPU (NVidia) Memory: 12GB, Driver date: 4-2-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.12
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Intel(R) UHD Graphics (Intel) Memory: 128MB, Driver date: 2-21-2024 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-2-2024
Driver Version: 31.0.15.5212
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 12282 MB

Rhino plugins that do not ship with Rhino
C:\Program Files\Bongo 3.0 (64-bit)\Rhino6\Bongo.30.rhp “Bongo 3.0”
C:\Program Files\Bongo 3.0 (64-bit)\BongoEtoUI.rhp “BongoEtoUI” 1.0.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

That is very unusual, especially for the specs.

A quick troubleshooting method is to copy your Rhino Desktop Shortcut and add a no splash screen flag on startup.

Can you roll back the video driver?

“C:\Program Files\Rhino 7\System\Rhino.exe” /NoSplash

Hi Japhy,
Thanks for the reply.
Opening via the New & Recent tabs on the splash screen will cause a crash.
Opening via the Open tab and also clicking on the License tab on the splash screen doesn’t cause a crash.
The previous video driver was causing a crash after the Windows update which is why I updated the driver.
I can still use Rhino but would obviously like to sort out the crashing issue.

Hi Cian -
I suppose it wouldn’t hurt with a Repair of the Rhino installation from the Windows Control Panel.
-wim

Hi Wim,
Thanks for the reply, as a precaution did a repair before emailing in.
Cian

Hi Cian -
Just to make sure, …
Disable the Bongo plug-in in the Plug-in Manager and restart Rhino. Does that change anything?
-wim

Hi Wim,
Yes that is where the crash is coming from.
Disabled Bongo and no crash using the Splash Screen.
Checked on V7 & V8.
Cian