Rhino crashing during optimiztion

Hi Guys,

I am working on this algorithm for environmentally optimizing a tower. Unfortunately, 30-40 mins into the optimization process, Rhino crashes, I don’t know the reason, but I think it’s the honeybee components, because I tried using DIVA instead, and it didn’t crash. Can you please take a look to see if there’s anything unusual about the definition that might cause the crash?

Here’s a screenshot of the whole algorithm and shape of the form, to get an idea

And here’s the grasshopper file itself for some probing :blush:
Question.gh (517.4 KB)
Please make sure to set the boolean in the 3 red groups to true for the analysis to take place.

Thanks a lot

Hi - I’ve had this running here for over 5 hours without any crash.


I don’t know what could cause this to crash on your system.
You might want to run the Rhino SystemInfo command and copy-paste the result here to check if there are any “usual suspects” and perhaps you could check availability of RAM on your system when this is running.
Other than that, for questions related to Ladybug and Honeybee, you could check the dedicated forum - perhaps someone has run into this before.
https://discourse.ladybug.tools/
-wim

1 Like

How do I run the SystemInfo command please?

You type SystemInfo in the Rhino command line and press enter. The same way all commands are run in Rhino.

well I tried, and I got “unknown command” :cold_sweat:

Hi -

That probably means that you are running Rhino 5.
What we usually check in the SystemInfo is the use of third party plug-in but especially the dates of the drivers for the GPU(s). When a crash happens 30-40 minutes into a process, the first thing that comes to my mind, though, is an issue with running out of memory or your machine overheating.
-wim