Rhino crashes when attaching a worksession

Hi I am experienceing an issue where Rhino crashes when attaching a worksession. This seems to have only started occuring in the most recent update (I have worked with these file before without any issues) and only applies to large files (>300MB).

I was finally able to successfully attach the workession by opening the file separately and turning most of the layers off, but this was much slower that previously.

There doesn’t seem to be any computer resource spikes at the time of crash and there is no crash report to send to McNeel.

Is it possible to roll back to the previous version of Rhino?

Version: Rhino 6 SR13 (6.13.19058.371, 27/02/2019)

Hello - can you please run SystemInfo in Rhino and post the results?

-Pascal

See Below:

Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: Educational, build 2019-02-27
License details: Cloud Zoo. In use by: Charlie Harris ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: IMACPC

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 780M (NVidia) Memory: 4GB, Driver date: 5-1-2017 (M-D-Y). OpenGL Ver: 4.5.0 NVIDIA 382.05

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 5-1-2017
Driver Version: 22.21.13.8205
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\Charlie\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.3.1.650\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Tibidabo\Lands.rhp “Lands Design”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - can you please open Options > Plug-ins page, and locate the Vray and Tibidabo plug-ins, disable it (check box) and the restart Rhino - does that change the worksession behavior at all?

-Pascal

Hi Pascal.
It doesn’t seem to be any faster or more stable when the plugins are disabled.

i work with several 300-700mb worksession attachments all the time, no issues with the recent updates.

Primary laptop: Primary display and OpenGL: NVIDIA Quadro K4100M (NVidia) Memory: 4GB, Driver date: 11-1-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 416.78

Hello - just to make sure - Rhino is starting from scratch with these three plug-ins already disabled:

VRay
Tibidabo LandsDesign
Tibidabo

correct? And Worksession > Attach crashes Rhino?

-Pascal