Rhino continues to crash [SOLVED]


(Jeff Lasor) #38

I understand that it happened the first time…obviously that’s not supposed to happen… however, the evaluation version does have a “disabled save” feature that might have kicked in prematurely for some reason… which is why I’d like clarification on your term “crash”

Thanks,
-Jeff


(Aderosa) #39

Sorry, you are right. Rhino doesn’t stop running. Few seconds after the popup you see appears, a window that invites me to send the crash report appears but Rhino continues working.


(Jeff Lasor) #40

Ok thanks…yes that is definitively a crash…

Please try this:

When that “invite to send dump” dialog appears, do not dismiss it…just move it over to the side so that you can see your desktop… You should see a file named “RhinoCrashDump.dmp” (note: not the .3dm but the .dmp file). If you can locate that dmp file, please post it here.

Thanks
J


(Jeff Lasor) #41

The reason you should not dismiss the dialog before posting the file is because Rhino deletes it automatically once you close the dialog… so please send in the dmp file before closing that dialog.


(Aderosa) #42

RhinoCrashDump.zip (16.6 MB)


(Jeff Lasor) #43

Sorry I just reread your last post… and saw that “rhino continues to run”… which means there may not actually be a rhino Crash dump file…

We may want you to try a non-evaluation version just to rule out the “disable save” feature somehow acting up… Have you changed your date settings in any way since you installed Rhino? Just wondering what might have set this off…


No way to use Version 6
(Aderosa) #44

No Jeff, no date setting change. Anyway in the previous reply I added the dump in zip format. Maybe it could be useful anyway.


(Jeff Lasor) #45

Thanks! I’m starting to look at it now…will let you know what I find.

-J


(Jeff Lasor) #46

Well the crash dump indicates that it’s happening down inside Microsoft’s DX (DirectX) core module…which is usually indicative of issues related to the user interface inside of Windows. Rhino’s new user interface is apparently using something that is causing bad things to happen inside of “mscordbi.dll”, and as of right now, I have no idea what that would be.

What were the options you disabled in PS to get things working? Description(s)? Name(s)? just curious.

Sorry if this has already been covered, but it’s just easier to ask it again here if it has… Do you have your Windows fully updated?

Also, I’d like to try something if you’re willing…

There have been some pretty bad Dell/Windows combinations out there of late having to do with Intel GPUs and NVidia “hybrid” configs… It is my own belief and assumption that Dell’s pre-install of Windows onto their systems is just bad, and can create some pretty bad co-existing issues with drivers…especially in the video graphics department… Everything seems fine out-of-the-box, but that’s because Dell ensures that their pre-installs work on their systems…and the pre-installs are “fixed” in version. However, once out in the real world, when the laptops start updating themselves with Windows updates and other software, that’s when the collisions start to happen… Anyways, long story short… there is some bad configuration that exists on certain hybrid configs that can rear its head after a series of updates and installs…but we have now way of knowing what that is…only that the combination of multiple GPU makes and models is the root cause.

With that said, I am curious what happens if you disable the the Intel GPU altogether…

  1. Start the Device Manager (right-click the Windows logo in the lower left task tray, and select Device Manager).
  2. Expand the “Display adapters” node… You should see both your GPUs (Intel and NVidia)
  3. Right-click on the Intel GPU and select “Disable device” and then select “Yes” to any dialog that appears.
  4. The screen may flash, but you should be returned to your screen…

With that done, only the NVidia GPU will be in use, and there should be no collisions between drivers or modules being used in ANY application…So if this is the problem on your system, then with the Intel GPU disabled, you shouldn’t see the problem anymore…if you still see the problem, then obviously it’s something else and I probably need to bring the UI devs into this conversation, since it seems UI related.

Note: I’m not suggesting that this is a solution…It’s only a diagnostic process to see if the problem is related to what I think it is… We have one possible solution, but it’s a lengthy one, and we’ve only seen it work on very specific configurations exhibiting similar problems.

It’s your call…but please let me know if you do decide to try this and what the outcome was.

In the mean time, I will continue investigating any known issues with “mscordbi.dll” and crashes.

Thanks for your help and patience on this… and although we’ve seen similar issues in rare cases, your situation currently is unique, which is why we’re all having a harder time resolving it…but your help and patience is very much appreciated.

-Jeff


(Jeff Lasor) #47

Note to disabling the Intel GPU above… please make sure no other applications are running at the time you disable the GPU… In fact, I would start with a clean boot of Windows, then disable the Intel GPU…then see if Rhino works.

-J


(Aderosa) #48

@Jeff i need to thank you so much. Since I bought this new XPS by Dell i was struggling with NVIDIA Card.
I performed a clean installation of the Nvidia drivers and forced WIN10 to use only Nvidia as main GPU.
The things gone better but Photoshop, Maya crashed again, but Rhino saved!
But when i disabled Intel GPU the magic happened! No crash by PS, no crash by Maya and now Rhino saves! :slight_smile:
One question… is now a safe environent to run with Intel card disabled?


(Aderosa) #49

The only thing that i cannot do is to manage the brightness and some troubles with some Dell apps.
Anyway I reactivated the card and the problem appeared again :slight_smile:


(Jeff Lasor) #50

It’s definitely a safe environment…and for most applications (especially the ones you’ve listed) it’s the preferred environment… But a little background…

The whole purpose (concept) behind a hybrid system is done for one reason and one reason only… Power Management. A graphics processor (GPU) can take up quite a bit of power, even when doing the simplest task… So the idea behind hybrid systems is that you have 2 GPUs…one that isn’t very powerful (aka, not very good) and therefore uses less power, and one that is very powerful and can do all kinds of cool graphics tasks at amazing speeds. Given those two GPUs, the system (Windows) can now decide which GPU to use for which tasks, and thus, “try” to better manage the power usage and consumption on systems that run on batteries (i.e. Laptops). So when something like Notepad is being used, there really is no need for a high powered GPU just to render and draw text, and so Windows will not load the high-end graphics drivers into Notepad’s process space, thereby forcing the use of the Intel GPU…which in turn reduces the power consumption, and thus maximizing the batter life…at least that’s the theory… The reality? … Most applications today provide some sort of graphical capabilities, whether it’s something like Maya or Rhino trying to pump out rendered 3D frames as fast as it can, or something like a word processor that also allows inserting pictures and even videos into their documents…the bottom line is that even the most simplest application today will most likely benefit from the higher-end GPU…and so users prefer that over “battery life”… It’s also why you now need to specify which GPU you’d like to use for which application…and as I said, most users today, when asked that question, will always answer “I want the better GPU to be used, after all, I paid a premium for it!”…right? And I’m still not even convinced that theory really works (at least not very well, and not the way it was intended)…it’s also thrown all kinds of logistics and management issues into the mix, which as you’ve experienced, can cause additional problems under the hood.

So having said that… Disabling the Intel GPU is no different than if you had bought a laptop with only an NVidia GPU installed…and the end result will “supposedly” be that your laptop battery will drain faster than if you only had an Intel GPU…but I haven’t seen any real data to back that up. What I have seen and have personally experienced is that the best way to extend your battery, and get the best up times, is the Screen Brightness…that LCD on your laptop consumes a crazy amount of power, and I’ve personally experienced that just turning the brightness down by 50% can almost double my battery usage…which far better than any kind of automated GPU switching could ever do…mainly because as I said, most users will want/prefer speed and capabilities over longer battery life…especially when running graphics-intense applications like Maya and Rhino, and/or games… So the theory behind hybrid systems is a good one…but in practice, I don’t believe it lives up to the desired or expected outcome…but what it does do is create complicated and complex software problems that are almost impossible for 3rd party developers to figure out or even solve.

When I get a laptop, and I’m not planning on using it for testing Rhino, I almost immediately disable the Intel GPU :slight_smile: …when there’s another GPU available of course.

So… what now? Well, as I mentioned earlier, we’ve come up with a process that can “fix” the situation permanently…but have only seen it work on very specific configurations… We typed up a document explaining the process, and it’s posted here:

https://docs.google.com/document/d/e/2PACX-1vR-ovSL28Z8RE_3DRVCVlXh14kP4jTm1nQmIi-BbJHWU2MUEqtYoJPiqC0CeRpobTxghaosXUaqmfYU/pub

But don’t let the title confuse you…the problem was originally found on some systems as “frozen viewports”…but in reality, the problem is related to hybrid configurations and how Dell pre-installs its drivers for the GPUs. The basic concept behind the solution is to completely wipe your system clean of any and all GPU drivers and do NOT let Windows update them automatically (this is done by disabling your Internet connection during the process, and you’ll see that it’s mentioned in the document)… Then once all video driver crud has been wiped off the system, you then manually install the “proper” drivers for your NVidia GPU, and then let Windows update the Intel GPU drivers itself…again this is all mentioned in the document I wrote.

But again, it’s your call if you want to try going through the process… If you do decide to, I suggest reading over the document in its entirety first, before actually jumping into it. Just know that we have seen this not work on some configurations but have seen it work incredibly well on most system experiencing similar issues. So after going through the tedious process, you may be no better off than you are now…but there is a possibility that everything works.

Let me know what you decide, and if anything worked.

Thanks again for your patience, this type of problem is not an easy one to solve…especially since it’s really not related to the software we write.

-Jeff


(Gustavo Fontana) #51

Yesterday I was having lots of trouble trying to get a Vive Pro VR headset to work connected to my Dell 7720 ( I know it was in theory capable to run VR well). It turns out the switchable graphics was causing the problem. I turned it off in BIOS and forced the system to always be on Nvidia video card, and now everything works.

There’s only one thing you are supposed to do with Dell apps once you buy your Dell: uninstall all of them, they are garbage.

I hope this helps,

G


(Aderosa) #52

Jeff, the procedure explained in the doc works great for me.
The only changes i applied is to reboot in safe mode and use DDU (Display Driver Uninstaller) to uninstall both the GPU drivers. Actually everything works fine :slight_smile: I will keep you updated.


(Aderosa) #53

Now I’m scared that Windows Update can overwrite these drivers, since I see that the Intel utility for Display Setting is not installed on my Dell. Is there a way to block Windows to upgrade a specified driver?


(Jeff Lasor) #54

Actually if it worked then you should be good to go. It’s not Windows that messed things up in the first place, it’s Dell and their pre-install… Windows update for the Intel drivers is actually what fixes this problem… but only after you completely remove what Dell has done.

Hope that makes sense.

Glad things are finally working for you. sorry you had to go through all this, but there’s really nothing Rhino could have done to avoid it… thanks for sticking through it and being patient.

-Jeff


(Aderosa) #55

I can’t agree more…I have an annoying problem with the crackling in the audio that is still not resolved.

PS. Please add a way to transfer the license by Mac to PC. People like me that have bought the version for Mac need to buy it again for PC :frowning:


#56

You can buy an upgrade (half the full license price) to Rhino V6 with your V5 for Mac license. The V6 license is valid for the current Rhino V6 for Windows as well as the future V6 for Mac.


(Aderosa) #57

So I can upgrade to 6 by my Rhino 5 on Mac? Can I do online? Is there a link?