Rhino continues to crash [SOLVED]

No way to use Rhino on my brnad new Dell XPS 15.
I’ve made all the updates, both driver and OS.
Any suggestion?

Rhino 6 SR1 2018-1-23 (Rhino 6, 6.1.18023.13161, Git hash:master @ 92a80e9e2b29e4670a94deb0d656e234ca1fe036)

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Intel® UHD Graphics 630 (OpenGL ver:4.5.0 - Build 24.20.100.6287)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.5
Shading Language: 4.50 - Build 24.20.100.6287
Driver Date: 8-15-2018
Driver Version: 24.20.100.6287
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

We are already on 6SR11, I suggest you update to latest Rhino and see if things are better there. Lots of changes since the 6SR1, including fixes to crashes for Intel UHD Graphics 630 GPUs.

Unfortunately tried and nothing changes…
I’ve tried also to force to run on the integrated GPU but nothing…

Rhino 6 SR11 2018-12-14 (Rhino 6, 6.11.18348.17061, Git hash:master @ 600b621e607cf5226a968db60d7ac9230541b94d)
Licence type: Evaluation, build 2018-12-14
License details: Cloud Zoo. In use by: Antonio De Rosa ()
Expires on: 2019-03-21

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: XPS15-ADR

Intel® UHD Graphics 630 (OpenGL ver:4.5.0 - Build 24.20.100.6287)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.5
Shading Language: 4.50 - Build 24.20.100.6287
Driver Date: 8-15-2018
Driver Version: 24.20.100.6287
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

In addition now I’ve always a problem with the Save PopUp Dialog… I cannot save nothing…

Hi @aderosa - What exactly happens? You are able to open up Rhino, correct? Is it crashing when rotating the view? WIth a specific file or running a specific command? Any patterns that cause the crashes?

Hi Vanessa.
First of all I can’t save anything. Anytime I try a popup dialog appears with that reports Unable to save the file…

If draw or create any solid and then try to “play” a bit with the Perspective view, changing the render view, the program crashes.

The crashes seem to be related to the graphic card…
About the saving issue, are you saving locally or to a network drive?

Always locally. I’ve a brand new Dell XPS 15 with Nvidia 1050ti

Both SystemInfo outputs show you are using the built-in GPU (Intel UHD Graphics 630) - you should try the discrete GPU, your Nvidia GTX 1050ti instead.

No way to force Rhino to use. I tried also in Stetings/Cycles to set CUDA on Nvidia but the crashes continues…

Just setting CUDA for Raytraced/Cycles isn’t enough. You need to make sure you have your laptop configured such that the Nvidia GPU is the primary display adapter, not the built-in Intel GPU.

I don’t know how to do it for your laptop, but it could be a boot time setting, or just check the nvidia settings panel. You’ll have to ask the internet how to exactly ensure the Nvidia GPU is your primary GPU for your laptop.

I will try and keep you updated. What about the error on saving files?

I’ve forced Rhino to use the NVIDIA GPU and it seems more stable but i cannot save any file…

@aderosa, I would check that the locations you write to are actually writable. Other than that…
@Vanessa do you have any other ideas why saving would fail?

For sure is writable…It’s my usual locations…

In Windows Control Panel > power options, is your system set for High Performance? Balanced and Power Save both can interfere with Windows switching to the better NVIDIA adapter.

Also, are you running on only the built in laptop display?

John, now Rhino is running in High Performance and it seems good. No crashes. The only issue at the moment is the fact that I cannot save. Yes, i’m running on the built-in display.

Since this isn’t a typical problem, I’m at a loss to guess what is special about your setup. Sorry we’re not much help.

Are you plugged into a docking station or have some special USB device(s) connected?

Nothing…but strage thing… if I run on Intel 630 and disable CUDA…it saves for a while but keep crashing…

Hello - any Windows updates available? A new machine will not have the latest.

-Pascal