Rhino Compute AppServer couldn't load custom .gh file error


I’m very excited and been learning Rhino Compute last couple of weeks, but the learning curve of this backend/webserver concepts are quite steep that I have faced a lot of issues along the way.

Basically, I want to run a custom .gh code on Rhino Compute, visualizing a small box on webpage. But it gives me an error of Meshing failed: component "Mesh Brep" (72ed398b-a578-4f58-9974-055a23635e73) on rhino.compute terminal and also Exception Thrown System.NullReferenceException: 'Object reference not set to an instance of an object.' on the line 912 of GrasshopperDefinition.cs

This is a simple code that I am trying to visualize:

I’ve tried different algorithms too, simple “Hello” “world” a simple string concatenation and it still doesn’t load on the screen.

You can see from the video what exactly happening on my machine.

Furthermore, /examples files load without any issue but most of the /files gives same error on GrasshopperDefinition.cs file.

simpletest_meshout3.gh (10.0 KB)

I’d appreciate if anyone shed light on the cause of the issue.

Thank you.

When I load the “dresser” example from /view, it gives me an error of 500 (Internal Server Error) on browser console.

on the network tab, the fetching has an error

I’ve installed Virtual machine on my pc and installed a clean rhino grasshopper without any plugin but it still gives the same error.

Additionally, I’ve turned off the firewalls in order to check but still shows the same issue.
Could anyone confirm that at least the dresser example work on their end?

Thank you.

One thing to keep in mind is that not all of the definitions will work in the /view endpoint. The definition you post should.
Not sure why the mesh brep component is failing though. Do you mind sharing that definition?

Hello Mr.Luis
The definition is on the original post.

But as for your convenience, I upload here again.

simpletest_meshout3.gh (10.0 KB)

I have also made a post on the forum again.

and its very simple gh file but still can’t render the mesh.
the file is here:

fatbox.gh (5.3 KB)

Thank you for checking.

My reply in the other post also covers this one