Rhino causes bluescreen when closing file

Hey, I have to following issue:

When i close and opt to save a file, Rhino causes a bluescreen (nearly everytime). After rebooting, all Rhino settings are resetted (OSnap, mouse options, window layout etc.). Sometimes it can cause the file to be damaged and not readable anymore - probably when the bluescreen happens in the saving process.

I already tried the following steps to fix the issue:

  • disabled all non Rhino plugins
  • completely recovered Windows and intsalled everything from scratch
  • also happening with the RhinoWIP version
  • also tried it on several completely different files

I can not explain this issue… it didnt happen before (only since the last week)

One area where it doesnt seem to happen is in Safe Mode. But of ourse this mode is unusable, since it is very slow to work with large files.

I am running a relatively new ThinkPad X1 Extreme and also attached the _systeminfo .txt-file!

Any help would be highly appreciated!

Greetings from Vienna, Rudi

system_info.txt (1.6 KB)

Hi Rudi - can you try, first save the file - let this process finish - then close Rhino - is that any different? Are you saving to the local disc? And does it happen if you do not save on closing at all?



  • Yes, I forgot to mention… This seems to be much more stable. However sometimes it even happens when I just close the file (having saved it already before)…
  • And yes I am saving on my local disk.

Thank you for the reply!

Hi Rudi - have you rebooted the machine ‘cleanly’, that is, with no blue-screen involved? Are there any available Windows updates?


Hey Pascal,
yes I did and there are no new windows updates available…

I attached a video, where I open an .dxf file for example, save it as .3dm and close Rhino afterwards.

What display mode is the “Active” viewport in when you save the file? What happens if you set ALL viewports to Wireframe and try saving… Do you still get blue screens? I’m just wondering if the blue screens are GPU related. And the reason the GPU is involved here is because Rhino renders a small thumbnail image of the active viewport, which then gets saved in the file.

IMO, it sounds like faulty hardware…which can happen sometimes. Do you have any USB devices plugged into the ThinkPad? If so, try removing them and see if the blue screens go away. Sometimes knocking a USB device with your knee or desk can damage the hardware, which can result in blue screens, either random or reproducible. It’s also possible that your hard drive is going bad, which would be very unfortunate…but again, it can happen sometimes.

Blue screens are always caused by what is known as “Ring 0” software…which is drivers and/or firmware, and not a result of “Ring 3” applications, like Rhino. However, applications can obviously cause the blue screens to happen simply by using the hardware and/or drivers that eventually blue screen…which makes it look like the application is the cause.

Have you tried any other software that can save and read files?

Can you please translate exactly what is shown in the blue screen you show in your video? It might actually mention the piece of hardware that caused the crash.


  • concerning the display mode: I usually work with shaded/rendered, but in this case it was Wireframe. (But thank you for the additional information about the involvement of the GPU, always excited to learn more in depth stuff!
  • to the hardware: no external devices plugged in. I am running a NVIDIA GeForce GTX 1050 Ti Max-Q with 4GB
  • other software: I tried opening the same file with AutoCAD, make some changes to the mesh and save it, but it worked fine. Same with e.g. Photoshop…
  • to the nature of bluescreens: very interesting! On the bluescreen, it doesnt say anything particular… Just that there is a problem, therefore information will be collected and the PC has to be restarted - which actually doesnt happen afterwards… it just goes to 100%, the fans turn on and it stays like that.

Thank you for your suggestions Jeff!

My older machine at home has started to blue-screen (no Rhino involved) now and then for no obvious reason - I also get this 100% state ‘for ever’ until I force the machine off.


Another related thread:

This user said that rolling back the latest Windows updates sorted it out for him. That seems too bad,as a solution though.


Found this on a website

Over the past few weeks, Microsoft has been hit by a number of bugs that have been pushed out in recent updates to Windows 10.

These included not being able to use the Windows Media Player properly and an issue where users began complaining that files were being deleted after installing the latest Windows 10 update.

Now it seems this software has been hit by yet another bug which is leaving some facing a blue screen error.

In a post on their support page Microsoft has confirmed the issue saying: “After installing this optional update some users have reported getting a blue or black screen with error code, “System thread exception not handled.”

“As a precaution, we have removed this optional update from Windows Update and Microsoft Update Catalog to protect customers.

“Fixes and improvements will be available in the December 2018 security update release and will include a resolution for this issue.”

1 Like

Hi Mitch - thanks - so another update, is the deal… but undoing the last is legit way out too, I guess.


Yeah, guess so. If you browse around a bit, you will find quite a few recent reports. Seems that MS Surface Book 2’s were affected among others…

Wow, thank you guys. So I basically have to downgrade my windows right?

Hope that works, I´ll reply later :slight_smile:

very interesting, checked for updates again just in case (i had already checked some time before) and SURPRISE: there is a update, installed it and it worked like magic … at least until now, did some tests, everything worked fine!

Thank you again for your help!



I was just offered a new Windows update as well - it will update when I shut down I guess. Hopefully this sorts it all out for everyone that’s having this problem.