Rhino blocks keyboard functionality

Hi Everyone,

This is a weird one, but here goes. Whenever I open Rhino, I cant make a capital T by pressing “shift+T”, however it works if I use caps lock. And this error persists through every software I have open when Rhino is open.

The weird thing is when I close down Rhino the error disappears and I can make uppercase “T” by pressing “shift+T”.

I have checked the keyboard shortcuts in rhino and reset them to defaults without any luck.

Additionally I have installed all updates to my pc, plus an additional update to its keyboard drivers, still with no luck.

I am using the most recent version of both rhino 5 and 6 - same problem occurs with both versions.

I look forward to getting this problem solved.



Hi Jens - can you please run the SystemInfo command in Rhino and post the results here?


Hi Pascal,

heres the info you requested:

Rhino 6 SR11 2018-12-14 (Rhino 6, 6.11.18348.17061, Git hash:master @ 600b621e607cf5226a968db60d7ac9230541b94d)
Licence type: Commercial, build 2018-12-14
License details: Cloud Zoo. In use by: Jens Pedersen ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESKTOP-SS6DLPR

Radeon 500 Series (OpenGL ver:4.6.13543 Compatibility Profile Context 25.20.15002.58)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 12-6-2018
Driver Version: 25.20.15002.58
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.11.18348.17061
C:\Users\JensPedersen\AppData\Local\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino.Plugin” 2.4.18345.806
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Does it also happen when you run Rhino in safe mode?

Hi Wim,

yes it does! but why is that? and would you suggest that I continue to use the safe mode version of rhino?



That was just a step in troubleshooting.

Let’s see - you still cannot use Shift + T to make an uppercase T when running in safe mode? (Just making sure that I understand the answer correctly…)

No I can, sorry for being unclear, when I am in safe mode, shift + t works both in rhino and other software.

:smile: Cool - that’s how I first read the answer but then I changed my reply because I wasn’t sure anymore.

Anyway, as the next step, I would then suggest blocking the Enscape plug-in and see if the problem stays away.

Ok, silly question (since I dont use a lot of plugins - besides GH) - how would I disable the plugin, remove the toolbar file, from the toolbar folder? or should i simply uninstall enscape?

I think I realized why it isnt working now, I set a hotkey for making images in enscape, that as far as I remember is shift+T - and therefore might have overwritten its general functionality. I will test this now

Jep, that fixed it! Thank you very much for all your help!

1 Like