Rhino BETA 2017-Nov-7 Available Now!


(Brian Gillespie) #1

Rhino is now in BETA! Get your copy now!

What is BETA? We’re not adding any new features, nor are we making significant changes to the UI. We’re also done breaking the APIs, so plug-ins written for this Beta will work in the commercial release of Rhino 6.

For the next few builds, we’ll be wrapping up documentation, localization, and working with our third-party developers to get their plug-ins ported to Rhino 6.

New this week:

Usability Problems Fixed:

  • Snapshot: Restoring a wrong view can’t be canceled (RH-42281)

Bug Fixes:

  • Annotation: Backslash handling from Python wrong (RH-41685)
  • Annotation: Dot: Incorrect location (RH-42319)
  • Annotation: Hatch: Display wrong with certain combinations of CPlanes and view directions (RH-42325)
  • Annotation: Leader: Scriptable Leader fails to add the string (RH-42237)
  • Annotation: Text: Cannot change the font (RH-42229)
  • ApplyDisplacement: Displacement broken on model (RH-42341)
  • Cycles: RhinoCycles.DpiScale not properly registered (RH-42259)
  • Display:
    • Adding point light makes textures on object not show up (RH-40786)
    • EMap in Rendered mode generates confetti on VMWare (RH-42219)
    • Ground plane material isn’t shown in Rendered mode (RH-42128)
    • Locking blocks forces a wireframe display (RH-42252)
    • Points show through objects in Rendered and Raytraced modes (RH-42129)
    • Text masks do not mask dimension lines (RH-42137)
    • ViewCapture of skylight shadows are downgraded on high dpi when they should not be. (RH-42356)
    • Wireframe models in perspective view not visible after loading file (RH-42314)
  • Documentation: RhinoCommon Overview and Getting started guides out-of-date for Rhino 6 (RH-41333)
  • ExtractSrf: Support Alt to toggle Copy (RH-42101)
  • File IO:
    • .wrl file does not import into Rhino (RH-42147)
    • IGES Import - Curve names are truncated (RH-42182)
    • Issues saving to V5 from V6 (RH-29995)
    • Step file that opens better in V5 than V6 (RH-42312)
  • Grasshopper:
    • Grasshopper internal OpenNurbs data should serialise using Rhino6 flavour. (RH-41748)
    • Relays inserted into hidden wires (RH-42160)
    • Wire arrows wrong. (RH-42159)
  • Help:
  • Make2D: Make2d Regression Tests Failing (RH-42105)
  • No Subsystem: No buttons visible in the ComboListBox (RH-41797)
  • OSnap: Toggle inside the Curve command behavior change (RH-42192)
  • OpenNURBS: Run TestONX_Model in Rhino for Mac to the opennurbs toolkit is working correctly on Mac OS. (RH-42153)
  • Orient: Show dots (RH-38514)
  • Rendering: Materials: Wildcard search doesn’t work (RH-42278)
  • SDK:
    • Export TL_SortPointList to the public C++ SDK (RH-42230)
    • RhinoFitCurve does not work property with polyline curves as input (RH-42326)
  • SDK: Python:
    • Expose RTree to Python SDK and RhinoCommon: PointCloudClosestPoints and PointCouldKNeighbors (RH-41282)
    • PlugInId function docstring example missing lines (RH-41830)
    • rs.DimensionStyle doesn’t function correctly when reading overridden dimstyle (RH-42304)
  • SDK: RhinoCommon:
    • Curve.Fair on periodic curves (RH-42127)
    • Curve.GetDistancesBetweenCurve bug (RH-41877)
    • ObjectTable.AddExplodedInstancePieces returns empty GUIDs (RH-42305)
    • PushModelTransform not working in PostDrawObjects channel (RH-42380)
  • Snapshot: Snapshots memory leak (RH-42246)
  • UVEditor: Drawing with inverted depth mode (RH-41627)
  • ViewCaptureToFile:
    • Default to PNG and make extension stick (RH-41975)
    • PCX, TGA and TIFF formats don’t work with ViewCaptureToFile (RH-42293)

Download Now and report any problems in this forum.


AMD ProRender Rhino Beta Plugin...any info?
#2

https://www.rhino3d.com/download/rhino-for-windows/beta/changes
This one throws a 404…
(linked from the download page)

https://www.rhino3d.com/download/rhino/wip/changes
still works and is updated with 2017-11-07 data.


#3

Hi,
does it need a different license?
I have the following message:

“Unable to update license for Rhinoceros 6.0”

Thanks,
Dmitriy


#4

Solved, just need to log in again. :slight_smile:
Normally doesn’t ask me to log in…


(Steve Baer) #5

3 posts were split to a new topic: Vector Printing Bug With Dimensions


Vector Printing Bug With Dimensions
(Bob McNeel) #7

(Marc Gibeault) #8

It doesn’t work here… not even a splash screen.
It works in safe mode though… and when started as an administrator.
@brian something you’re aware of?


#9

Loaded and works for me with no problems - same as previous WIP versions.


#10

I have got an invitation to rhino 6. I would like to test it. But it does not accept my Rhino 5 License. And it does not find my License in the Rhino account online. I can not even enter it. Because the system only accepts Rhino6 Licenses. Any help?


#11

Same situation here. This need some attention.


#12

Congratulations to all of you McNeel 3D nerds. I’ll be testing it regularly now.


#15

That’s a bizarre question to ask on the official newsgroup. Also a bit funny, since if you have to go through IT to install anything on your work computer, a crack isn’t going to solve that. So you should get friendly with them.


(Brian Gillespie) #16

When you downloaded you should have received an email that said “Welcome to Rhino BETA”. In it is a link to get your license key - does that work?


#17

Hi,

If I have an educational license can I download Rhino 6? If so what’s the process, since the serial number has a different format.

Thank you,


#18

Did you try putting your Rhino 5 license key (not serial number) in the appropriate field on this page?
https://www.rhino3d.com/download/rhino-for-windows/beta


(Brian Gillespie) #19

Can you please try repairing the installation from control panel? This sounds really strange.


For Rhino V6 wishlist
(Brian Gillespie) #20

Fixed!


(Marc Gibeault) #21

It worked… thanks.

EDIT:
@brian sorry, it did not work, I had the shortcut start as administrator…
When I start as a standard user, nothing happens except a 100MB Rhino.exe process


(Marc Gibeault) #22

Is there something else I can try to find the problem?
Thanks


#23

Works for me! Looks great.

Where do I post a problem? My Macros aren’t working same as in v5. Brought in a Toolbar. Buttons look different (some don’t have my custom button-thumbnail) and more importantly, the macros aren’t working. Same exact verbage in both macro buttons.

Here’s one that works in v5 but not v6

**
! -_ChangeLayer “04 Heavy”
-_Copy _Pause _InPlace _SelNone _SelLast _Offset _Cap=_Flat
_Distance 6 _Pause _Pause _Enter
_Selnone _Sellast _SetObjectName “Temp”
-Hatch Pause Enter Pattern “Solid” Enter
_SelNone _SelLast
-_ChangeLayer “07C Hatch grey”
_SelNone _-SelName “Temp” _Delete
_SelNone _SelLast "

**