RHINO 8 WIP unreadable file

Hi all. I am really upset with Rhino 8 WIP. I am unable to laod a file that was saved with Rhino 8. It is saying unable to read the file. The file was working fine 2 hrs ago. Now its not opening. Please some one help.
Base1.3dm (13.8 MB)

The Rescue3DM command brings back…some geometry? I don’t know how much was lost.

What was this stored on, a network share, local drive?

1 Like

I tried the command but its not able to load it. It was on local drive

Well, judging by the file size some was lost…

What’s your backup process?

Base1 recovered.3dm (9.8 MB)

I am not able to see any backup file. Thank you for trying, but nothing recovered. I am attching an image of the file i worked on below,
Screenshot 2023-07-03 at 11.34.28 PM

check your trash for an unused autosave… you may be able to recover some data there.

1 Like

I meant what sort of backup procedures do you have? If you don’t…well it’s past time to have backups, it’s incredibly important.

There’s no way of knowing what caused this file corruption without knowing a lot more about your system, seeing the -systeminfo results…and probably having a not-broke file and knowing what you were doing when it failed.

1 Like

I have a good news. I used a recovery software from web to find backup file on my drive. Luckily I was able to recover a backup file with that software and no data was lost. Thank you @JimCarruthers @theoutside for your help. But still i dont know why the saved file failed!

1 Like

wip software occasionally has issues because it’s well… a work in progress… we never recommend using it for production work without a pretty robust backup system in place.

I personally use carbonite for all my mission critical files and it’s been super reliable for a decade or so. I also keep a local copy and a 2nd copy in a cloud drive of any files that are work for hire, so I actually have 3 copies of any critical file at any time.

glad you found a backup and are back up and running.

Well, to be complete about this, this is not a problem that is uniquely related to a WIP software. We have had reports of this kind of thing in Rhino 7 as well. And Rhino 6. And Rhino 5… Search the archives here and you will find them.

Yes, occasionally files get corrupted - nobody really knows why, some kind of error occurring while the system is saving, some fluke combination of factors or circumstances that nobody can reproduce systematically, who knows. In any case, as others have said, backups are the only defense against this happening - in WIP or ‘production’ software.

1 Like