Rhino 8 SR0 2022-10-4 (Metal Issue )

As in previous builds TestMetal make viewports go black with some display modes on.
Working display modes:

  • wireframe
  • shaded
  • rendered
  • xray
  • artic
  • raytraced (but extremely slow)

Black Viewport Issue affected display modes:

  • Ghosted

not working at ll (viewport remain as is)

  • Technical
  • artisitc
  • pen

please refer to https://discourse.mcneel.com/t/rhino-8-sr0-2022-9-20-metal-issue-is-back/148078 for the behaviour.
systeminfo Rhino 8 SR0 2022-10-4.txt (5.1 KB)


Have to update, after a boolean subtraction while using X-Ray the issue was there too.

Hi Marco -
Could you try a few things and see if any of that makes a difference?
I see you’re on macOS 12.5.1 - could you update to 12.6?
Does it make a difference if you only use one monitor?
Is this issue model-specific, or does it also happen with, e.g., a simple sphere in a new document from a factory-default template?
-wim

So did two test:
On the same MacMini M1 as first post report (MacOS 12.5.1) detaching second Monitor (HDMI) and using the one on the USB-C/Thunderbolt connector the issue remains as soon as I switch to Ghosted. (I suppose it should happen on X-Ray too at this point.)

Second test:
MacBook Pro M1 Pro (14") with no external monitor *(MacOS 12.6) no issue at all when using Ghosted nor X-Ray. !!!

(btw, Technical, artisitc, pen are not working all . Are they still not available on this WIP build?)

I’m going to update Macmini to 12.6 too and than report to you.
Here it is:
sysinfoMacBookpro14.txt (12.1 KB)

Updated the MacMini to 12.6.
Issue is still there when switching to ghosted as per attached videograb.


systeminfo Rhino 8 SR0 2022-10-4-MacoS12.6-MacMiniM1.txt (5.1 KB)

Further test on the MacMini.
Detached the first Monitor (Huawei Mateview USB-C) and used only the second one (AOC HDMI) :
New file model: just a cube, made a boolean subtraction with another cube and no issue on the various display mode available.

WIP model of an historical building: no issue on the various display mode available.
systeminfo HDMI-Rhino 8 SR0 2022-10-4-MacoS12.6-MacMiniM1.txt (5.0 KB)

At this point I wanted to try and use the Mateview with HDMI connection too instead of the USB-C and it has worked for a while before starting to go dizzy

systeminfo HDMI(HuaweiMateView)-Rhino 8 SR0 2022-10-4-MacoS12.txt (5.0 KB)

EDIT----
I noticed that in all the display modes (except for wireframe and rendered mode, which stay ok) as soon as I zoom in the model and the view became more complex (much more stuff to render I suppose) it start to slow down and scatter on zooming/panning/rotation and then the display issue appear.
The issue seems to be more consistent across using USB-C than HDMI but I’ve met it even using HDMI,

UPDATE for MacBookPro 14 tests:
after a while, in a similar zooming situation like on Mini (close up of the model) using Ghosted mode the display went dizzy.
It worked but just longer if compared to MacMini.