Rhino 8 selection of anno dots

Unable to select an anno dot by clicking anywhere on it other than relative center. Is there an ‘Advanced options’ fix for this?
Rhino 7 I can basically click anywhere on a dot to select it.
Please fix.
thank you,
Robert

I’m not seeing much if any difference in from V7 to V8 in this regard here…

Hi Robert -

… did you get anywhere with that one?
-wim

weird. Its impossible for me to select a dot in 8 unless i’m basically centered on it. And this is HEAVILY zoom related… zoom way out and the mouse pointer gets even further from ‘dot center’ so absolutely won’t select unless centered.
I think my advanced mouse settings are pretty standard, low mouse radius a/p how i had in 7… attached.
7:


8:

Hi Robert - does the same dot in an otherwise empty file select the same way?

-Pascal

Hi Pascal, yes same behavior.
Can you reproduce on your end? make a dot, and zoom WAY OUT like miles a way. I cannot select the dot unless mouse is centered on dot. (window and crossing select work fine)

Hi Robert -
image

Selection seems fine so far… must be some step I am missing. Are your dots default size?
image
(Seems to make no difference, here.)

-Pascal

I think I see your issue… try making a much longer text bubble, like an annotation for a drawing, not a single letter or number like ‘x’.

Ie: make a annotation and put in at least a full word with 7 letters or more. But the bug on my end is EXTREMELY exacerbated by a long text…

this one took forever to select…

Hi Robert, that seems not to matter here I tried that as well

But mine working is neither here nor there- can you send us a file, with the dot and view set so that it does not work right, and also please post the results from the SystemInfo command?

-Pascal

oh strange. ok. will do now. but good to see it works for you.

Pascal, this def seems related to the file. I tried the test in a ‘no template’ scenario and I didn’t have the issue. In ‘my’ custom template I get the issue, attached here.
dot issues.3dm (6.0 MB)

Hi Robert - thanks - if I delete the layouts, it works… :man_shrugging:

I’ll get it on the heap…
RH-78771 Selection - dots and layouts

-Pascal

1 Like

I’m gonna try remaking new templates with new geo and see what happens… those layouts have geo and stuff coming from v6, maybe even v5 at this point, so who knows what’s lurking in there…

1 Like

RH-78771 is fixed in Rhino 8 Service Release 2

slightly off topic, but still Dots, there used to be a tab in the print dialogue box where you could add a value to the size of Dots, in V8 this option is no longer there ? @brian @pascal

Hi Miles -

I’m recycling RH-71644 for this one.
-wim

1 Like