Rhino 8, Script Editor Creating / Saving Projects Fails on .NetFramework

Hello @eirannejad .
I’m really excited for the scripteditor functionality of creating quick plugins from Python / Gh1.
It seems that I cannot create or save the existing project while I’m in .NetFramework,
while it works flawlessly under .NetCore.
As a Fellow RIR user, I don’t think I’ll switch my rhino to use .NetCore anytime in near future.
Thank you

1 Like

@tay.othman What errors are you getting when building plugins? Run RhinoCodeLogs to see more about the errors and share that here if you don’t mind. Thank you!

I get the error below:
image

Below is the Log file
ScriptEditor.txt (17.2 KB)

@tay.othman Seems like there is an issue with the file path. What’s the file name you are trying to save the project as?

Hello @eirannejad . I was not able to start a project at all. And currently I have no open projects.

Okay I’m not following. Would you mind giving the steps to replicate this error so I can investigate the bug?

@eirannejad here is what I’m trying to do.

again, it works fine under. NetCore. this issue is exclusive to .NetFramework.

Oh I see. I can replicate this now. Thanks for reporting and I’ll get it fixed for Tuesday release.

RH-77722 Create project in .NETFramework throws an error

1 Like

@eirannejad
Hi Ehsan,
I have almost same problem in publishing the project. My error is “Failed getting NETFramework reference assemblies”. Can you help me?

1 Like

@Hadi_Yazdi

Are you running your rhino instance under . NetFramework or .NetCore?

I tried both. but it didn’t work, same error.

1 Like

I couldn’t reproduce your issue, can you first try with a simple grasshopper definition. just to make sure it is not caused by a third-party libraries.

I was able to publish it from my side,

@Hadi_Yazdi HI

This is a known issue and I have a ticket for this. Thanks for reporting. I will update when this is fixed

RH-75990 Publishing fails due to missing Newtonsoft.Json

2 Likes

thanks @eirannejad, I follow the discussion

I’m in the same situation as @Hadi_Yazdi.

1 Like