Rhino 8 Plotter plotter custom size issue

Anyone have issues with plotter custom size settings in Rhino 8.
Plotter is Canon TM - 305.
I normally change custom sizes through File/Print/Properties/Page SetUp.

No problem doing this in v7, no reaction to input in v8.
Any other way around this?
Reverted back to v7.

Hi Dave -
Please run the Rhino SystemInfo command and copy-paste the result here.
-wim

Hi -
Rhino 8 SR6 2024-4-10 (Rhino 8, 8.6.24101.05001, Git hash:master @ 32c244aa711e0034e75bec2e87d093c764820b96)
License type: Commercial, build 2024-04-10
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 64GB)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 4080 Laptop GPU (NVidia) Memory: 12GB, Driver date: 12-6-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 546.33
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 4080 Laptop GPU (NVidia) Memory: 12GB, Driver date: 12-6-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 546.33
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 6-15-2023 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-6-2023
Driver Version: 31.0.15.4633
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 12282 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

I am also having this issue on a Canon TX-4000.

In Rhino7, I would go to the properties box here.

Then change paper size in this dropdown:


In Rhino7, the size would automatically change to “Custom Size”. In Rhino8, the size automatically changes to US Photo 16"x20", no matter what size I put in the printer properties.

If I manually change the size to “Custom Size”, then the printer properties overwrite my custom size settings to A4.

That looks like a bug to me.
Maybe with these steps @stevebaer can figure it out.
It may be difficult to fix this since no one in Rhino development or support has one of those large format printers. Hopefully it’s a general printing issue and not specific to the Canon printer.

As a work-around, you can print using the RhinoPDF printer, then send the resulting PDF file to your plotter.
That should work.

You can also try the Rhino 8 Service Release Candidate 7.
In Rhino Options > Updates and Statistics > Update frequency > Service Release Candidate.

Thanks

This is the first thing to try. I believe this may have been fixed recently

1 Like

I am using version 8 SR6 (8.6.24101.5001, 2004-04-10). I am working on getting IT permission to run the 8.724121.13001 update.

Thanks, please let me know if you still see the bug after updating to 8.7.

Yes, this issue is still present in 8.7

Converting RhinoPDF did not work because Acrobat froze every tried to print from it. I was able to set up custom paper sizes then print using those.

In the plotter properties dialog, go to “Size Options…” and create a Custom Paper Size and hit Add.

If you close and reopen the Rhino print dialog, the new size will appear as an option.

Thanks Ben.
Best solution as of yet.