Rhino 8 Mac: Grasshopper: ⌘+ C = disable node

I just installed Rhino 8 Mac.
In Grasshopper when I do: ⌘+ C, instead of copying the selected node, the clipboard remains empty and the node is disabled.
I still have Rhino 7 installed and have no issues there.
In Settings>Interface> Shortcuts, everything looks good.
When I select a node, and select the copy function from the menu, that works fine.
It’s just the keyboard shortcut: ⌘+ C that is not working.
Restarted Rhino & computer.
Not sure what else to check.
Screenshot 2023-11-28 at 10.37.28

Screenshot 2023-11-28 at 10.38.07

In case my original post wasn’t clear,
I am restating the behavior I am experiencing:

In Rhino & Grasshopper (and every other app),
when I want to copy (and then paste) something,
I select the item and use the keyboard shortcut ⌘+ C.

This has worked fine in all previous versions of Rhino & Grasshopper.

However, in Rhino 8 Mac Grasshopper,
instead of copying the selected node,
when I use the keyboard shortcut ⌘+ C,
the node is disabled.
(And the clipboard remains empty)

When using the menu commands Edit>Copy & Edit>Paste
everything works fine.

If you use the menu command Edit>Copy,
then the keyboard shortcut for Paste (⌘+ V) DOES work.

What is not working is specifically the keyboard shortcut for Copy (⌘+ C).

When using ⌘+ C on a selected node, the node becomes disabled.

I attached images above from Grasshopper Settings showing that my keyboard shortcuts are correctly mapped.

For the meantime, I am copying nodes by holding the option (alt) key while dragging the node.

This works fine, but I think it will be nice if ⌘+ C also works :slight_smile:

⌘+C is working fine for me in Rhino 8 BETA on an M1 Mac. I can’t remember if this has always been the case, but Option dragging only works if you hold down the key after beginning to drag the node. Holding Option down before dragging a node adds a separation boundary thingy to expand the canvas.

I figured out the issue I was having with ⌘+ C.

I was using ⌘+ F3 as a keyboard shortcut for “Disable Selected” and for some reason this was causing ⌘+ C to behave like “Disable Selected”

After I removed the keyboard shortcut ⌘+ F3 for “Disable Selected”
then ⌘+ C began working properly again.

1 Like