Rhino 8 - Decal crash

It is getting rather demoralising when you are mid workflow. I do try and save reasonably frequently, but sometimes I am just in a naturally good flow of work, and obviously Rhino provides zero help doing automatic saves and such, at random.

I am spending more of my time in the AppData folder hoping there is a backup there, or the .bak files are working, but usually they don’t. Nothing in Recycle bin, as usual.

I have no idea why, but Rhino is also obsessed with “preparing procedurals for first time use”, and it makes absolutely no sense why it does this, even when I make no material changes. What is being used for the first time? Why is it not caching?

The decal system is very slow on my system, and I am at a loss to understand why.

This time, it was a decal operation I was doing. For the first time in forever, Rhino actually offered a Crash Report, which I did send.

Anyway, I have given up for now, given it has set me far back enough, and I have lost the will to live for the moment with these crashes. However, this SR8 seems much less stable than the SR5 and SR6 I was using before.

Also, thanks CrashDump, that’s really helpful…

image

Rhino 8 SR8 2024-6-18 (Rhino 8, 8.8.24170.13001, Git hash:master @ c3cc7c123163b65d85b517aff795627d5b12166b)
License type: Commercial, build 2024-06-18
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 32GB)
.NET Framework 4.8.9241.0

Computer platform: DESKTOP 

Standard graphics configuration.
  Primary display and OpenGL: NVIDIA GeForce RTX 4090 (NVidia) Memory: 24GB, Driver date: 5-7-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.44
    > Accelerated graphics device with 4 adapter port(s)
        - Windows Main Display attached to adapter port #0
        - Secondary monitor attached to adapter port #1

Secondary graphics devices.
  NVIDIA GeForce RTX 4070 SUPER (NVidia) Memory: 12GB, Driver date: 5-7-2024 (M-D-Y).
    > Accelerated graphics device with 4 adapter port(s)
        - There are no monitors attached to this device!
  Intel(R) UHD Graphics 770 (Intel) Memory: 128MB, Driver date: 1-18-2024 (M-D-Y).
    > Integrated graphics device with 4 adapter port(s)
        - There are no monitors attached to this device!

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  Graphics level being used: OpenGL 4.6 (primary GPU's maximum)
  
  Anti-alias mode: 4x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: High
  
  Vendor Name: NVIDIA Corporation
  Render version: 4.6
  Shading Language: 4.60 NVIDIA
  Driver Date: 5-7-2024
  Driver Version: 31.0.15.5244
  Maximum Texture size: 32768 x 32768
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 32768 x 32768
  Total Video Memory: 24564 MB

Rhino plugins that do not ship with Rhino
  C:\Program Files\Cyberstrak\R8\CS_ModelingPlugIn.rhp	"Cyberstrak Modeling PlugIn"	
  C:\Users\David\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\NVIDIADenoiser\0.4.3\NVIDIADenoiser.Windows.rhp	"NVIDIADenoiser.Windows"	0.4.3.0
  C:\Users\David\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\RhinoFileVersion\7.0.8486\RhinoFileVersion.rhp	"Rhino 3DM File Version"	7.0.8486.27751
  C:\Program Files\Doliwa Workshop\Rhino Nature\Rhino Nature.rhp	"Rhino Nature"	1.0.4.16355
  C:\Users\David\AppData\Roaming\McNeel\Rhinoceros\8.0\Plug-ins\Bella (813de3fb-18eb-405f-bfcd-b0b4d3da91fb)\24.2.0.0\bella_rhino.rhp	"Bella"	24.2.0.0

Rhino plugins that ship with Rhino
  C:\Program Files\Rhino 8\Plug-ins\Commands.rhp	"Commands"	8.8.24170.13001
  C:\Program Files\Rhino 8\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp	"Rhino Render"	8.8.24170.13001
  C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	8.8.24170.13001
  C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp	"MeshCommands"	8.8.24170.13001
  C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	8.8.24170.13001
  C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	8.8.24170.13001
  C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
  C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp	"Displacement"	
  C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp	"SectionTools"	

Hi David, Are you still seeing the issue with these 3rd party plugins disabled? Go to Rhino 8>Settings>Plugins and sort by plugins that do not ship with Rhino & disable. Thanks

I see the bug report, it happened in RhinoCycles code. FWIW, decal updates in Raytraced don’t work very well, at least when changing the underlying material. This has been a problem already since Rhino 7. A satisfactory solution has yet to be created.

Anyway, the bug for the crash is: RH-82804 Crash in decal code

Thanks for sending in that report, it should help in finding a fix.

Hi both, and thanks.

I can use the Rendered mode or such if needbe.

Actually, I can repeat my work that took about an hour in probably 10 minutes now I have reflected on my (inefficient) approach. So I can stop having hissy fits. I just wish the crash reporting system was fixed.

Cheers,

David.

well, you did send in one, and it’ll be hugely helpful! Lets take the small win, savour the moment, then worry about the other crashes that don’t get reported after :wink:

I have been investigating this for a bit, but unfortunately the callstack does not make sense.

Can you try see if you get a crash with decals after you have disabled all third-party plug-ins?

Sure! Shall I try this in Raytraced mode again? I’ve been reverting to Rendered, which has been reasonably okay, but still rather laggy I must say.

In raytraced please. This where the crash happens according the report you sent in before. I just want to make sure it happens also with the third-party plug-ins disabled, ruling out those doing anything naughty.