Rhino 8.3 Error When Using Legacy GHPython for the First Time

This used to be - probably still is - an issue in Rhino 6 and 7 on macOS, when launching a Grasshopper file from Finder, without opening Rhino first.
The file would usually launch Rhino, then Grasshopper, and when the GH file would contain a now legacy GHPython component, this exact exception would pop up.