Rhino 8.0 lagging when dealing with a large of environments loaded

I was trying out the v8 studios one by one, and it started to get real slow and slower at each environment I added to the file, to a point where Rhino freezes for a while when adding a new one and setting as an active environment:

And when loading a new env, all others apear as the aplied environment, but seems just a visual bug, when rendering, the last env. that was set is still the one being used.

After recording this first clip, I deleted 14 environments at once from the list and Rhino just froze completly. Only after a few minutes later the progress bar appeared, so at least I knew Rhino hadn’t completely crashed.

It took Rhino 12 full minutes to delete the selected 14 environmens, only then it was responsive again.

Just for the sake of it I pressed CRTL+Z, and all env. came back instantly. No delays. Then I pressed CRTL+Y, and they all were gone instantly, no issues this time.

I then added one env. back, and this time everything went smoothly:

My point is: why is Rhino struggling to deal with all this environments?

And as related matter, IMO the progress bar Its a very useful feeback tool, it should appear way more often, maybe for everything that takes more than a few 2 seconds? Why not?

Please post the results of the Rhino command _SystemInfo

Sorry @nathanletwory, here it is:

Rhino 8 SR1 2023-11-21 (Rhino 8, 8.1.23325.13001, Git hash:master @ 8a4a437248efac5d9cb04d3904481b83e4c23a64)
License type: Evaluation, build 2023-11-21
License details: Stand-Alone
Expires on: 2024-02-28

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 32Gb)
.NET 7.0.14

Computer platform: LAPTOP  - Plugged in [100% battery remaining]

Hybrid graphics configuration.
  Primary display: Intel(R) Iris(R) Xe Graphics (Intel) Memory: 1GB, Driver date: 7-11-2023 (M-D-Y).
    > Integrated graphics device with 4 adapter port(s)
        - Windows Main Display is laptop's integrated screen or built-in port
  Primary OpenGL: NVIDIA GeForce RTX 3070 Ti Laptop GPU (NVidia) Memory: 8GB, Driver date: 8-4-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 536.99
    > Integrated accelerated graphics device with 4 adapter port(s)
        - Video pass-through to primary display device

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  Graphics level being used: OpenGL 4.6 (primary GPU's maximum)
  
  Anti-alias mode: 2x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: High
  
  Vendor Name: NVIDIA Corporation
  Render version: 4.6
  Shading Language: 4.60 NVIDIA
  Driver Date: 8-4-2023
  Driver Version: 31.0.15.3699
  Maximum Texture size: 32768 x 32768
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 32768 x 32768
  Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
  C:\Program Files\Rhino 8\Plug-ins\Commands.rhp	"Commands"	8.1.23325.13001
  C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp	"WebBrowser"	
  C:\Program Files\Rhino 8\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp	"RhinoScript"	
  C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp	"IdleProcessor"	
  C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp	"Rhino Render"	8.1.23325.13001
  C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp	"Legacy Rhino Render"	
  C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	8.1.23325.13001
  C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp	"MeshCommands"	8.1.23325.13001
  C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	8.1.23325.13001
  C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp	"RhinoCodePlugin"	8.1.23325.13001
  C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	8.1.23325.13001
  C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
  C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp	"Displacement"	
  C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp	"SectionTools"	
  C:\Program Files\Rhino 8\Plug-ins\SolidTools.rhp	"SolidTools"	
  C:\Program Files\Rhino 8\Plug-ins\RhinoBonusTools.rhp	"Rhino Bonus Tools"	
  C:\Program Files\Rhino 8\Plug-ins\export_STL.rhp	"STL Export"	
  C:\Program Files\Rhino 8\Plug-ins\AnimationTools.rhp	"AnimationTools"	
  C:\Program Files\Rhino 8\Plug-ins\Calc.rhp	"Calc"	


You should update to at least Rhino 8.2, but if possible try the release candidate for the next service release 8.3. You can change that through Help > Check for Updates… by setting frequency to Service Release Candidate.

Let me know if that alleviates the problem.