Rhino 7 "Shaded () Not Available"


I tried searching for similar posts but I couldn’t find one exactly the same.

After installing Rhino 7, both SR0, SR1. My Rhino Shaded Views always have a yellow bar on the bottom of the viewport with “Shaded ( ) Not Available” The views then become very sluggish. I barely can rotate or pan them. I do have V-Ray 5 plugin installed.

Does anyone know what happened with my Rhino7?

Best Regards,

Hi Jay -

Please run the Rhino SystemInfo command and copy-paste the result here.

Do you also see that when you first disable V-Ray and then relaunch Rhino?

Rhino 7 SR1 2020-12-8 (Rhino 7, 7.1.20343.09491, Git hash:master @ 350b20978b4fcd75493212fbd3c4248983612f86)
License type: Not For Resale Lab, build 2020-12-08
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-25-2019 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 2060 (NVidia) Memory: 6GB, Driver date: 9-14-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 456.38
> Integrated acclerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-14-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
C:\Program Files\ADA 3D\Mesh2Surface for Rhino 6\m2s_for_Rhino.rhp “MESH2SURFACE”
C:\ProgramData\McNeel\Rhinoceros\6.0\Plug-ins\Twinmotion Direct Link 2020.2 (e24ee14a-9514-47da-8fe6-f6e61b20160e)\Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

After setting render back to Rhino Render. I disable V-Ray to load the plugin. Saved the file an restart Rhino7. It crashes every time.

I have to open Rhino7 with a blank template then it opens up and the SHADED VIEW becomes normal. The yellow bar at the bottom is gone.

Hi Jay -

As opposed to which start-up template or specific file? Is that something that you can post here?

This looks like the “Raytracing” HUD for things like “Raytraced” mode…So something has clearly messed up the display mode ID’s for your modes… I have no idea how or what could have done this.

I would try going into Options->View->Display Modes and delete your Shaded mode (and any other modes that exhibit this problem) and then close the Options dialog. Rhino will then recreate the mode(s) with the defaults.

See what that does.


Hi Wim,

That’s the file that I found the issue all the time. After disabling the V-Ray Plugin. I’m not able to open this file anymore. My Rhino 7 crashes all the time when I open this file.

Test_V_Ray_5_grass.3dm (1.8 MB)

Hi Jeff,

I’ll have to enable back V-Ray and try what you suggest. I’ll let you know how it goes.


@jvic - your file probably has a V-Ray viewport visible. To get around that import your 3dm into a new file. That will probably get around your problem.

Hi Wim

After removing SHADED display mode from the display setting. Then reloading the V-Ray plugin back and select it as the render engine, the problem was gone. Now the shaded mode displays without any yetllow bar at the bottom of the viewport. It runs perfect now. Thank you for the solution.