Rhino 7 Rendered/Raytraced Viewport Bug

,

I’m using the latest version of Rhino 7 for Mac and noticed that when I have the Rendered viewport active it actually switches to the Raytraced viewport. It’s also flipped when I select the Raytraced viewport it very clearly switches to the Rendered viewport. Anyone else having this bug?


In your top screenshot I see Rendered mode being used.

In your bottom screenshot I see Raytraced mode being used, but it hasn’t started drawing its results to the viewport yet therefor you see the dumbed down OpenGL drawing before Raytraced has its first ready.

On the Mac there is for Raytraced and Rhino Render only CPU rendering. To get results to the viewport more quickly you can go to Preferences > Cycles and move the sharpness and response sliders a notch to the left, then toggle the Raytraced viewport again. Keep moving the sliders to the left and toggling the viewport until you have a speed that is satisfactory.

Sharpness: moving slider to the left makes Cycles use bigger pixels. This results in blockier renderings in the viewport, but each notch means only 25% of the work to do of the previous level.

Responsiveness: Cycles starts with even bigger pixel size until the sharpness setting has been achieved. This helps in viewport responsiveness when tumbling the viewport, or making changes to the model.

If you have a Mac machine with AMD GPU in you may want to try the ProRender plug-in from the _PackageManager. It’ll give you GPU accellerated rendering.

I’ve been using Rhino for years so take my word for it when I say I know what the OpenGL rendered viewport looks like. I also use Keyshot and I know what Raytracing looks like. The viewports are switched for some reason. In the rendered viewport it uses the OpenGL drawing for a second then starts Raytracing. In the raytracing viewport it only renders in OpenGL and never starts raytracing.

Your first viewport definitely shows Rendered mode, not Raytraced.

To double-check add another sphere next to your first one, and give it a Metal material. If you see reflection of the one sphere in the metal sphere then you are correct, if not, then I am.

Your second screenshot shows Raytraced viewport, but raytracing hasn’t started. I know this because at the bottom you see the orange HUD that is characteristic for the Raytraced viewport. Since there are no results to show yet you see an (ugly) OpenGL version of the sphere.

Best regards,
/Nathan
Raytraced & Rhino Render dev.