Rhino 7 OBJ export problem

I’ve only just bought the upgrade to Rhino 7 and my first job was a simple ‘open and existing Rhino file and export an object as OBJ’.
This did not work. Rhino 7 just hangs, no error, ‘not responding’ message, nothing.
I tried doing the same job with Rhino 6 and it did it within seconds.
I also created a new object in a fresh Rhino 7 scene and tried to export this as an OBJ and I got the same problem.
This is a bit of a major issue, which means I can’t use Rhino 7 for my projects until this is fixed!

Has anyone else had this issue? If so does anyone have a solution?

Thank you all

Welcome @neilcorbould
Check Plug -ins for the Obj exporter2021-02-07_15-11-17

Hello Fred_C,
For a brief moment there I was very excited…
sadly, They are already enabled in the options/plug-ins.

Or did you mean somewhere else?


No you are at the right place.

edit: Are you running the latest Version 7?
(7.3.21026.13001, 1/26/2021)

Please post a V7 .3dm file of the item you want to export as an obj. file.

Hi @neilcorbould

If you select the export OBJ plugin which version does it report?
If you right click and select Load plug-in what happens? Do you then see Yes on the Loaded column?

Hello Fred_C,
I have the problem with any objects. Even a simple cube made in Rhino.

1 Like

Hello Jussi,
The version that is displayed next to my export_OBJ plug in is:

That’s all I can tell you as Rhino locks up/hangs if I click on ‘details’ (although, ‘esc’ un-freezes it… small cancellation)

Do you mean pressing escape brings Rhino back to life? It almost sounds like there is a message box hidden somewhere asking for something. If you hold down ALT and keep pressing TAB can you see anything that could be a message box?
Can you load other plug-ins that are not loaded automatically when Rhino starts?
Please, run _SystemInfo command in Rhino and paste the output here.

1 Like

Thank you all very much for your insight, it is great to know a wonderfully knowledgeable and friendly forum is out there for such issues.

I attempted to create an export an object as an .OBJ file today, and it worked without a hitch!

The only difference being that this time I did not have my second monitor connected.
I had this exact problem with a completely different piece of software yesterday and I think there is a weird issue of (Like Jussi mentioned) windows getting lost in the ‘no-mans-land’ between screens.

I haven’t as yet investigated this with a view to fixing this weirdness but at least I can take heart that it is not an issue with Rhino (or the other software) and comfortably carry on with my work.

Again Thank you to everyone for you help, you’re the best.


Good luck. :+1: